zoukankan      html  css  js  c++  java
  • E


    Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

    Description

    How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.



    Input

    The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

    Output

    For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

    Sample Input

    1.00
    3.71
    0.04
    5.19
    0.00
    

    Sample Output

    3 card(s)
    61 card(s)
    1 card(s)
    273 card(s)
    #include <iostream>     
    #include<cmath>                
    using namespace std;   
    int main()
    {
    double  t[10000];
    	t[0]=0;
    	int i=0;
    	for(;t[i]<=5.2;)
    	{
    		i++;
    		t[i]=t[i-1]+1.00/(i+1);
    	}
    	double x;
    	while(cin>>x&&x)
    	{
    		  int l, r;  
            l = 0;                  
            r = i  ;
            while (l + 1 < r) 
    		{  
                int mid = (l + r) / 2;       
                if ((t[mid] - x)<-0.0000001)      
                    l = mid;  
                else  
                    r = mid;  
            }  
            cout << r << " card(s)" << endl;    
            
    	}
    
    
    return 0;
    }


  • 相关阅读:
    Win10企业版远程桌面结合frp实现公网远程
    ibatis入门教程
    没找到工作的Java软件工程师是屌丝中的屌丝啊
    消息队列常见问题和解决方案(转)
    Mycat安装部署简单使用
    MySQL以及MyCat的安装和使用
    MyCat用户配置-添加用户、修改用户、删除用户、重置用户密码
    mycat的下载和安装
    CentOS基础命令大全 (转)
    唯一ID生成器。
  • 原文地址:https://www.cnblogs.com/claireyuancy/p/6768938.html
Copyright © 2011-2022 走看看