zoukankan      html  css  js  c++  java
  • hdu 4902 Nice boat--2014 Multi-University Training Contest 4

    题目链接:http://acm.hdu.edu.cn/showproblem.php?

    pid=4902



    Nice boat

    Time Limit: 30000/15000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
    Total Submission(s): 235    Accepted Submission(s): 116


    Problem Description
    There is an old country and the king fell in love with a devil. The devil always asks the king to do some crazy things. Although the king used to be wise and beloved by his people. Now he is just like a boy in love and can’t refuse any request from the devil. Also, this devil is looking like a very cute Loli.

    Let us continue our story, z*p(actually you) defeat the 'MengMengDa' party's leader, and the 'MengMengDa' party dissolved. z*p becomes the most famous guy among the princess's knight party. 

    One day, the people in the party find that z*p has died. As what he has done in the past, people just say 'Oh, what a nice boat' and don't care about why he died.

    Since then, many people died but no one knows why and everyone is fine about that. Meanwhile, the devil sends her knight to challenge you with Algorithm contest.

    There is a hard data structure problem in the contest:

    There are n numbers a_1,a_2,...,a_n on a line, everytime you can change every number in a segment [l,r] into a number x(type 1), or change every number a_i in a segment [l,r] which is bigger than x to gcd(a_i,x) (type 2).

    You should output the final sequence.
     

    Input
    The first line contains an integer T, denoting the number of the test cases.
    For each test case, the first line contains a integers n.
    The next line contains n integers a_1,a_2,...,a_n separated by a single space.
    The next line contains an integer Q, denoting the number of the operations.
    The next Q line contains 4 integers t,l,r,x. t denotes the operation type.

    T<=2,n,Q<=100000
    a_i,x >=0
    a_i,x is in the range of int32(C++)
     

    Output
    For each test case, output a line with n integers separated by a single space representing the final sequence.
    Please output a single more space after end of the sequence
     

    Sample Input
    1 10 16807 282475249 1622650073 984943658 1144108930 470211272 101027544 1457850878 1458777923 2007237709 10 1 3 6 74243042 2 4 8 16531729 1 3 4 1474833169 2 1 8 1131570933 2 7 9 1505795335 2 3 7 101929267 1 4 10 1624379149 2 2 8 2110010672 2 6 7 156091745 1 2 5 937186357
     

    Sample Output
    16807 937186357 937186357 937186357 937186357 1 1 1624379149 1624379149 1624379149
     

    Author
    WJMZBMR
     

    Source
     

    Recommend
     

    Statistic | Submit | Discuss | Note

    这道题理论上讲应该算是线段树的题,只是不知道CLJ怎么想的。

    。。数据微弱。

    。直接给水过了。

    。。

    从后往前,遇到1的情况就更新,更新完之后再往下看,遇到2的更新。

    #include<iostream>
    #include<algorithm>
    #include<cmath>
    #include<cstring>
    #include<cstdio>
    #include<vector>
    #include<bitset>
    #include<string>
    #include<queue>
    #include<stack>
    #include<set>
    #include<map>
    #include<cstdlib>
    using namespace std;
    #define CLR(A) memset(A,0,sizeof(A))
    const int MAX=100010;
    struct Node{
        int Q;
        int l,r,x;
    }t[MAX];
    int a[MAX];
    int gcd(int x,int y){
        if(y==0) return x;
        else return(gcd(y,x%y));
    }
    void solve(int Q,int i,int x){
        switch(Q){
        case 1:a[i]=x; break;
        case 2:a[i]=a[i]>x?

    gcd(a[i],x):a[i];break; } } int main(){ int T,n,m; while(cin>>T){ while(T--){ scanf("%d",&n); for(int i=1;i<=n;i++) scanf("%d",&a[i]); scanf("%d",&m); for(int i=0;i<m;i++){ scanf("%d%d%d%d",&t[i].Q, &t[i].l, &t[i].r , &t[i].x); } for(int i=1;i<=n;i++){ int j; for(j=m-1;j>=0;j--){ if(t[j].Q==1&&t[j].l<=i&&t[j].r>=i){ break; } } int k=j; solve(t[k].Q,i,t[k].x); for(int h=k+1;h<m;h++){ if(t[h].l<=i&&t[h].r>=i) solve(t[h].Q,i,t[h].x); } printf("%d ",a[i]); } printf(" "); } } return 0; }




  • 相关阅读:
    swiper.js 点击链接跳转后再次返回到轮播原位置
    KVO和KVC
    XML与HTML的区别
    iOS UIAppearance使用详解
    文件处理
    IOS 四种数据永久保存的方式
    UIImage图片处理(更改颜色,修改透明度,缩小,合并图片)
    从一个视图控制器切换到另一个视图控制器的几种方式
    NSString的常用方法
    NSURLRequest和NSURLConnection
  • 原文地址:https://www.cnblogs.com/claireyuancy/p/6820363.html
Copyright © 2011-2022 走看看