zoukankan      html  css  js  c++  java
  • hd acm1008

    Problem Description
    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
     
    Input
    There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
     

    Output

    Print the total time on a single line for each test case.
     

    Sample Input

    1 2
    3 2 3 1 0
     
    Sample Output
    17
    41
     
    Sample Way
     

    #include <stdio.h>
    #include <stdlib.h>

    int main()
    {
      int n,i,sum,floor[100]={0};
      while(scanf("%d",&n)==1&&n!=0)
      {
      sum=0;
      for(i=1;i<=n;i++)
      {
      scanf("%d",&floor[i]);
      }
      for(i=1;i<=n;i++)
      {
      if(floor[i]>floor[i-1]) sum+=(floor[i]-floor[i-1])*6;
      if(floor[i]<floor[i-1]) sum+=(floor[i-1]-floor[i])*4;
      }
      printf("%d ",sum+n*5);
      }
      return 0;
    }

     
  • 相关阅读:
    订单超时30分钟自动取消
    获取网络时间
    aspose.words通过域导出word文件
    Excel导入时,解析日期类型单元格的办法。
    ALTER TABLE 报1062
    mysql快速生成测试数据
    GP 源码编译安装
    Kafka 集群群起/关闭脚本
    Zookeeper 常用命令
    OGG 同步无主键表且目标表多一个隐藏字段
  • 原文地址:https://www.cnblogs.com/clljs/p/7423612.html
Copyright © 2011-2022 走看看