zoukankan      html  css  js  c++  java
  • poj 2253 (dis最短路径)

    Frogger
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 24979   Accepted: 8114

    Description

    Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
    Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
    To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
    The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

    You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

    Input

    The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

    Output

    For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

    Sample Input

    2
    0 0
    3 4
    
    3
    17 4
    19 4
    18 5
    
    0
    

    Sample Output

    Scenario #1
    Frog Distance = 5.000
    
    Scenario #2
    Frog Distance = 1.414
    

    Source

    Ulm Local 1997

    #include<iostream>
    #include<math.h>
    #include<iomanip>
    using namespace std;
    double G[210][210];
    int n;
    struct Point{
        double x,y;
    }a[210];
    float dist(Point a,Point b){
        return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
    }
    void dij(){
        double dis[210];
        int vis[210];
        for(int i=1;i<=n;i++)
            vis[i]=0;
        vis[1]=1;
        dis[1]=0.0;
        for(int i=2;i<=n;i++)
            dis[i]=G[1][i];
        for(int i=1;i<n;i++){
            double min=999999.0;
            int v;
            for(int j=2;j<=n;j++)
                if(!vis[j] && dis[j]<min){
                    min=dis[j];
                    v=j;
                }
            vis[v]=1;
            for(int j=1;j<=n;j++){
                double tmp=(dis[v]<G[v][j] ? G[v][j] : dis[v]);     //注意这里是最短路径变形
                dis[j]= tmp<dis[j] ? tmp : dis[j];
            }
        }
        cout<<setiosflags(ios::fixed)<<setprecision(3)<<dis[2]<<endl<<endl;
    }
    int main(){
        int cas=1;
        while(cin>>n&&n){
            for(int i=1;i<=n;i++)
                cin>>a[i].x>>a[i].y;
            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                    G[i][j]=dist(a[i],a[j]);
            cout<<"Scenario #"<<cas++<<endl;
            cout<<"Frog Distance = ";
            dij();
        }
        return 0;
    }
    


  • 相关阅读:
    #419 Div2 Problem B Karen and Coffee (统计区间重叠部分 && 前缀和)
    #418 Div2 Problem B An express train to reveries (构造 || 全排列序列特性)
    FZU 2203 单纵大法好 (二分 && 贪心)
    51Nod 1413 权势二进制 (思维)
    51Nod 1433 0和5 (数论 && 被9整除数的特点)
    POJ 2492 A Bug's Life (带权并查集 && 向量偏移)
    POJ 1456 Supermarket (贪心 && 并查集优化)
    POJ 1182 食物链 (带权并查集 && 向量偏移)
    #417 Div2 Problem B Sagheer, the Hausmeister (DFS && 枚举)
    #417 Div2 Problem C Sagheer and Nubian Market (二分 && std::accumulate)
  • 原文地址:https://www.cnblogs.com/clnchanpin/p/7281845.html
Copyright © 2011-2022 走看看