Problem Description
给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?
Input
第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x1, y1, x2, y2 (1 ≤ k ≤ 10, 1 ≤ x1, x2 ≤ n, 1 ≤ y1, y2 ≤ m),其中k表示gloria最多能转的弯数,(x1, y1), (x2, y2)表示两个位置,其中x1,x2对应列,y1, y2对应行。
Output
每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。
Sample Input
2
5 5
...**
*.**.
.....
.....
*....
1 1 1 1 3
5 5
...**
*.**.
.....
.....
*....
2 1 1 1 3
Sample Output
no
yes
分析:
特别注意:走过的点绝不可以标记,原因:如图三点1,2,3,假设1转弯数为5方向向下,2的转弯数为6方向向右,假设此时点2在队头,点2先搜到点3,如果把3标记,点3的转弯数为6,点1不能搜到点3,导致点3的转弯数不是最小,结果不言而知的wa。
很多人说用优先队列,但这题只要你标记了即使用优先队列还是不行,原因:假设1转弯数为5方向向右,2的转弯数为5方向向右,1,2的转弯数都为5都可在队头,假设此时点1在队头,点1先搜到点3,如果把3标记,点3的转弯数为6,点2不能搜到点3,导致点3的转弯数不是最小,结果不言而知的wa。
代码:
#include<string.h>
#include<iostream>
#include<queue>
using namespace std;
int t,n,m,k,x1,y1,x2,y2;
char tu[102][102];
int bj[102][102];
int next1[4][2]= {{1,0},{-1,0},{0,1},{0,-1} };
struct node
{
int x;
int y;
int step;
};
void bfs(int x,int y)
{
node now,next;
queue<node> q;
bj[x][y]=1;
now.x=x;
now.y=y;
now.step=-1;
q.push(now);
while(!q.empty())
{
now=q.front();
q.pop();
if(now.step>=k)
break;
for(int i=0; i<4; i++)
{
next.x=now.x+next1[i][0];
next.y=now.y+next1[i][1];
next.step=now.step+1;
while(1)
{
if(tu[next.x][next.y]!='*'&&next.x>=1&&next.x<=m&&next.y>=1&&next.y<=n)
{
if(next.x==y2&&next.y==x2&&next.step<=k)
{
cout<<"yes"<<endl;
return ;
}
if(!bj[next.x][next.y])
{
bj[next.x][next.y]=1;
q.push(next);
}
next.x=next.x+next1[i][0];
next.y=next.y+next1[i][1];
}
else
{
break;
}
}
}
}
cout<<"no"<<endl;
}
int main()
{
cin>>t;
while(t--)
{
cin>>m>>n;
for(int i=1; i<=m; i++)
for(int j=1; j<=n; j++)
cin>>tu[i][j];
cin>>k>>x1>>y1>>x2>>y2;
if(x1==x2&&y1==y2)
{
cout<<"yes"<<endl;
continue;
}
memset(bj,0,sizeof(bj));
bfs(y1,x1);
}
return 0;
}