zoukankan      html  css  js  c++  java
  • BFS写HDU1312 Red and Black

    Red and Black

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 25678    Accepted Submission(s): 15498


    Problem Description
    There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

    Write a program to count the number of black tiles which he can reach by repeating the moves described above.
     

    Input
    The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

    There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

    ’.’ - a black tile
    ’#’ - a red tile
    ’@’ - a man on a black tile(appears exactly once in a data set)
     

    Output
    For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
     

    Sample Input
    6 9
    ….#.
    …..#
    ……
    ……
    ……
    ……
    ……
    #@…#
    .#..#.
    11 9
    .#………
    .#.#######.
    .#.#…..#.
    .#.#.###.#.
    .#.#..@#.#.
    .#.#####.#.
    .#…….#.
    .#########.
    ………..
    11 6
    ..#..#..#..
    ..#..#..#..
    ..#..#..###
    ..#..#..#@.
    ..#..#..#..
    ..#..#..#..
    7 7
    ..#.#..
    ..#.#..
    ###.###
    …@…
    ###.###
    ..#.#..
    ..#.#..
    0 0
     

    Sample Output
    45
    59
    6
    13
     


    代码:

    #include <iostream>
    #include <queue>
    #include <cstring>
    using namespace std;
    int h,w,t;
    int mp[21][21];
    int dir[2][4]={ {1,-1,0,0},{0,0,1,-1} };
    char s[21][21];
    struct node
    {
        int x,y;
    };
    queue<node> que;
    void BFS(int x,int y)
    {
        node u,v;
        mp[x][y]=1;
        u.x=x;
        u.y=y;
        que.push(u);
        while(!que.empty())
        {
            v=que.front();
            que.pop();
            for(int i=0;i<4;i++)
            {
                u.x=v.x+dir[0][i];
                u.y=v.y+dir[1][i];
                if(s[u.x][u.y]=='.' && !mp[u.x][u.y])
                {
                    //BFS(u.x,u.y);
                    mp[u.x][u.y]=1;
                    que.push(u);
                    t++;
                }
            }
        }
    
    }
    int main()
    {
        int i,j;
        while(cin>>w>>h && h,w)
        {
            t=1;
            memset(s,0,sizeof(s));
            memset(mp,0,sizeof(mp));
            for(i=0;i<h;i++)
            for(j=0;j<w;j++)
            cin>>s[i][j];
            for(i=0;i<h;i++)
            {
                for(j=0;j<w;j++)
                if(s[i][j]=='@') break;
                if(s[i][j]=='@') break; 
            }
            BFS(i,j);
            cout<<t<<endl;
        }       
        return 0;
    }
  • 相关阅读:
    nginx学习编译安装(1)
    媒体查询
    web前端开发--超链接
    web前端开发--列表
    web前端开发--格式化文本与段落
    DIV与SPAN
    CSS基础
    表的创建
    数据库存储结构
    关系完整性约束
  • 原文地址:https://www.cnblogs.com/cnlik/p/11851881.html
Copyright © 2011-2022 走看看