zoukankan      html  css  js  c++  java
  • 01背包+卡精度 Hdu 2955

    <span style="color:#3333ff;">/*
    —————————————————————————————————————————————————————————————————————————————   
        author   :     Grant Yuan
        time     :     2014.7.19
        aldorithm:     01背包+卡精度
        
    —————————————————————————————————————————————————————————————————————————————
    E - 01背包 基础
    Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
    Submit
     
    Status
    Description
    The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university. 
    
    
    
    For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible. 
    
    
    His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
     
    Input
    The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
    Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
     
    Output
    For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set. 
    
    Notes and Constraints 
    0 < T <= 100 
    0.0 <= P <= 1.0 
    0 < N <= 100 
    0 < Mj <= 100 
    0.0 <= Pj <= 1.0 
    A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
     
    Sample Input
     3
    0.04 3
    1 0.02
    2 0.03
    3 0.05
    0.06 3
    2 0.03
    2 0.03
    3 0.05
    0.10 3
    1 0.03
    2 0.02
    3 0.05 
     
    Sample Output
     2
    4
    6 
    */
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cstdlib>
    #include<algorithm>
    using namespace std;
    
    int p[105];
    double f[105];
    int n,t;
    double  ff;
    double dp[100005];//抢到价值为i的钱逃走的最大概率
    int sum;
    
    int main()
    {
    	cin>>t;
    	while(t--){
    	   sum=0;
    	   scanf("%lf%d",&ff,&n);
    	   for(int i=0;i<n;i++){
    		scanf("%d%lf",&p[i],&f[i]);
    		sum+=p[i];}
    
    	   memset(dp,0,sizeof(dp));
    	   dp[0]=1;
    	   for(int i=0;i<n;i++)
    		   for(int  j=sum;j>=p[i];j--)
    		   {
    		   	dp[j]=max(dp[j],dp[j-p[i]]*(1-f[i]));
    		   }
            int m=0;
    		for(int i=sum;i>=0;i--)
    		{
    			if(dp[i]>=1-ff){
    					m=i;
    				break;}
    		}
    		cout<<m<<endl;
    	}
    }
    </span>

  • 相关阅读:
    (二十)WebGIS中图层树功能的设计和实现
    WebGIS中矢量切图的初步研究
    百度兴趣点下载工具设计和实现
    服务端常规知识详解
    Shp数据批量导入Postgresql工具的原理和设计
    浅谈C#中一种类插件系统编写的简单方法(插件间、插件宿主间本身不需要通信)
    从底层开发谈WebGIS中实现地理长度固定的可视窗口的思路和方法
    用存储过程判断某个人员在一天的行进轨迹中是否有超过指定时间的停留
    Linux启动与禁止SSH用户及IP的登录
    JVM中的垃圾回收
  • 原文地址:https://www.cnblogs.com/codeyuan/p/4254494.html
Copyright © 2011-2022 走看看