zoukankan      html  css  js  c++  java
  • 二分PkU3258

    <span style="color:#330099;">/*
    E - 二分
    Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
    Submit
     
    Status
    Description
    Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).
    
    To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.
    
    Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).
    
    FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.
    
    Input
    Line 1: Three space-separated integers: L, N, and M 
    Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.
    Output
    Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks
    Sample Input
    25 5 2
    2
    14
    11
    21
    17
    Sample Output
    4
    By Grant Yuan
    2014.7.16
    */
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cstdlib>
    #include<algorithm>
    using namespace std;
    int l,n,m;
    int low,high,mid;
    int a[50002];
    bool can(int k)
    {  int sum=0;
       int last=0;
        for(int i=1;i<n;i++)
          {if(a[i]-a[last]<k)
            sum++;
            else
              last=i;}
        if(a[n]-a[last]<k)
          return false;
        else if(sum>m)
          return false;
        return true;
    }
    
    int main()
    {
        while(~scanf("%d%d%d",&l,&n,&m)){
         for(int i=1;i<=n;i++)
           scanf("%d",&a[i]);
        a[0]=-1;
        a[++n]=l;
        sort(a,a+n+1);
        low=0,high=a[n];
        int ans=0;
        while(low<=high){
           mid=(low+high)*0.5;
           if(can(mid)){
             low=mid+1;
             ans=mid;}
          else
           high=mid-1;}
           cout<<ans<<endl;}
        return 0;
    }
    </span>

  • 相关阅读:
    Hibernate(九)HQL查询
    Hibernate(八)多对多映射
    Hibernate(七)一对一映射
    Hibernate(六)一对多映射(多对一)
    Hibernate(五)基本数据类型
    Hibernate(四)结构-基础语义和事务
    Hibernate(三)结构-配置文件-实体映射及配置文件
    Hibernate框架简介(二)基本使用增、删、改、查
    Hibernate生成实体类-手工写法(一)
    Java从零开始学四十(反射简述一)
  • 原文地址:https://www.cnblogs.com/codeyuan/p/4254514.html
Copyright © 2011-2022 走看看