zoukankan      html  css  js  c++  java
  • PKU 1276 Cash Machine

    <span style="color:#000099;">/*
    Cash Machine
    Time Limit: 1000MS  Memory Limit: 10000K 
    Total Submissions: 26604  Accepted: 9397 
    
    Description
    
    A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 
    
    N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 
    
    means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 
    
    Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 
    
    Notes: 
    @ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 
    
    Input
    
    The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 
    
    cash N n1 D1 n2 D2 ... nN DN 
    
    where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 
    
    Output
    
    For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 
    
    Sample Input
    
    735 3  4 125  6 5  3 350
    633 4  500 30  6 100  1 5  0 1
    735 0
    0 3  10 100  10 50  10 10
    Sample Output
    
    735
    630
    0
    0
    Hint
    
    The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 
    
    In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 
    
    In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.
    Source
    
    Southeastern Europe 2002
    pku 1276
    By ivi
    2014.7.1
    多重背包
    这道题从一开始的转化为01背包的超时,到后来的数组开小的运行时错误,再到超内存、、超时、、,
    到最后深夜1:40的AC,过程真辛苦
    */
    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    using namespace std;
    int f[13];
    int p[13];
    bool dp[111113];
    int num=0;
    int n=0;
     
    int main()
    {int temp,i;
       while(scanf("%d%d",&num,&n)!=EOF){
    
            for(i=1;i<=n;i++)
             scanf("%d%d",&f[i],&p[i]);
            if(num==0)
                cout<<"0"<<endl;
            else if(n==0)
                 cout<<"0"<<endl;
            else {
                memset(dp,0,num+3);
        m=0;
        dp[0]=1;
        for(int k=1;k<=n;k++)
                
              for(int j=m;j>=0;j--)
                  if(dp[j]){
                     for(int i=1;i<=f[k];i++)
                       {
                           temp=i*p[k]+j;
                            if(temp<=num)
                            {
                              dp[temp]=1;
                                if(temp>m)
                                  m=temp;
                                  }
                       }
                       }
            cout<<m<<endl;}
    
             }
       return 0;
    }
    </span>


  • 相关阅读:
    vuex入门
    element-UI快速上手例子运行失败
    Fix协议
    KDB+
    GO基础知识(基础数据类型之字符串、常量)
    如何实现一个通用的、高性能的排序函数
    线性排序(如何根据年龄给100万用户数据排序)
    【转】OpenResty 究竟解决了什么痛点
    idea项目常用的设置
    php站点ajax请求返回数据异常处理的经历
  • 原文地址:https://www.cnblogs.com/codeyuan/p/4254545.html
Copyright © 2011-2022 走看看