zoukankan      html  css  js  c++  java
  • (UVa 100) The 3n + 1 problem

     The 3n + 1 problem 

    Background

    Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

    The Problem

    Consider the following algorithm:

    1. input n

    2. print n

    3. if n = 1 then STOP

    4. if n is odd then tex2html_wrap_inline44

    5. else tex2html_wrap_inline46

    6. GOTO 2

    Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

    It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

    Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given nthis is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

    For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

    The Input

    The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

    You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

    You can assume that no operation overflows a 32-bit integer.

    The Output

    For each pair of input integers i and j you should output ij, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

    Sample Input

    1 10 
    100 200 
    201 210 
    900 1000

    Sample Output

    1 10 20 
    100 200 125 
    201 210 89 
    900 1000 174

    AC code:

     #include<stdio.h>

    int length(int n)
    {
        
    int count=0;
        
    if(n==1return 1;
        
    while(n!=1)
        {
            
    if(n%2!=0)
              n
    =3*n+1;
            
    else
              n
    =n/2;
            count
    ++
        }
        count
    +=1;
        
    return count;
    }

    int main(){
    int x, y, xx, yy, t, i, max;
    while (scanf("%d %d"&xx, &yy) == 2){
       
    if (xx < yy){
        x 
    = xx; y = yy;
       
       }
       
    else{
        x 
    = yy; y = xx;
       }
       max 
    = 0;
       
    for (i=x; i<=y; ++i){
        t 
    = length(i);
        
    if (t > max){
         max 
    = t;
        }
       }
       printf(
    "%d %d %d\n", xx, yy, max);
    }
    return 0;
    }
    作者:cpoint
    本文版权归作者和博客园共有,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接,否则保留追究法律责任的权利.
  • 相关阅读:
    菜鸟学自动化测试(三)—-selenium 命令
    菜鸟学自动化测试(二)—-selenium IDE 功能扩展
    用js实现自动打字动画效果
    hihoCoder #1015 : KMP算法
    hihoCoder #1014 : Trie树
    android相对布局中@id和@+id的区别(原理)
    android中动态给EditText获得焦点并弹起软键盘的方法详解
    网页版井字游戏(TicTacToe)人机对战的制作(附思路和源码)
    网页版番茄时钟的制作——Pomodoro Clock
    制作网页版简易计算器(Calculator)
  • 原文地址:https://www.cnblogs.com/cpoint/p/2015466.html
Copyright © 2011-2022 走看看