zoukankan      html  css  js  c++  java
  • (HDOJ 1013)Digital Roots

    Digital Roots

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


    Problem Description
    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
     

    Input
    The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
     

    Output
    For each integer in the input, output its digital root on a separate line of the output.
     

    Sample Input
    24 39 0
     

    Sample Output
    6 3
     

       Sample code:

       #include<stdio.h>

    #include<math.h>

    int root(int a)
    {
       
    int t=0;
       
    while(a>9)
       {
         t
    +=a%10;
         a
    =(a-a%10)/10;
        }
       
    if(t+a>9) t=root(t+a);
       
    else t+=a;
       
    return t;
    }

    int main()
    {
      
    char c[1001];
      
    int n;
      
    while(scanf("%s",c)!=EOF && (c[0]!='0'||c[1]!='\0'))
      {
        
    int a=0,i;
        
    for(i=0; c[i]!='\0'; i++)
        {
           a
    =a+c[i]-'0';
        }
        printf(
    "%d\n",root(a));
        memset(c,
    0,sizeof(c));
      }

     
    return 0;
    }
  • 相关阅读:
    转载:SuperMap 网络带宽对B/S项目的影响有多大?如何计算所需要的带宽?
    转载:使用JWT做用户登陆token校验
    转载:互联网在线地图平台对比分析
    jmeter计时器讲解
    ReactNative setNativeProps
    关于xxx.h file not found 的问题
    注册推送通知
    ios ViewController present不同的方向
    ReactNative常见报错
    ios 后台模式
  • 原文地址:https://www.cnblogs.com/cpoint/p/2063888.html
Copyright © 2011-2022 走看看