zoukankan      html  css  js  c++  java
  • 贪心 + 计算几何 --- Radar Installation

    Radar Installation

    Description

    Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 
    We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
      Figure A Sample Input of Radar Installations

    Input

    The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 
    The input is terminated by a line containing pair of zeros 

    Output

    For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

    Sample Input

    3 2
    1 2
    -3 1
    2 1
    
    1 2
    0 2
    
    0 0
    

    Sample Output

    Case 1: 2
    Case 2: 1
    
     

    【题目来源】

    Beijing 2002

    http://poj.org/problem?id=1328

    【解题思路】

    以每个岛的坐标为圆心画圆,会与x轴有2个交点,那么这2个点就是能覆盖该岛的雷达x 坐标区间,问题就转变成对一组区间,找最少数目的点,使得所有区间中都有一点。把包含某区间的区间删掉(如果一个点使得子区间得到满足, 那么该区间也将得到满足),这样所有区间的终止位置严格递增。

    每次迭代对于第一个区间, 选择最右边一个点, 因为它可以让较多区间得到满足, 如果不选择第一个区间最右一个点(选择前面的点), 那么把它换成最右的点之后, 以前得到满足的区间, 现在仍然得到满足, 所以第一个区间的最右一个点为贪婪选择, 选择该点之后, 将得到满足的区间删掉, 进行下一步迭代, 直到结束。

    ac代码:

    #include<iostream>
    #include<cstdio>
    #include<cmath>
    #include<algorithm>
    using namespace std;
    #define MAX 1010
    struct Node
    {
        float x,y;
        float l,r;
        bool vis;
    };
    Node node[MAX];
    int n;
    float r;
    bool cmp(Node a,Node b)
    {
        return a.r<b.r;
    }
    int main()
    {
    //    freopen("in.txt","r",stdin);
        int kase=1;
        while(cin>>n>>r)
        {
            if(n==0&&r==0)
                break;
            int i,j;
            int cnt=0;
            if(r<=0)
                cnt=-1;
            for(i=0;i<n;i++)
            {
                scanf("%f%f",&node[i].x,&node[i].y);  //血的教训,这儿用cout绝对超时
                if(node[i].y>r)
                    cnt=-1;
                node[i].l=node[i].x-sqrt(r*r-node[i].y*node[i].y);
                node[i].r=node[i].x+sqrt(r*r-node[i].y*node[i].y);
            }
            printf("Case %d: ",kase++);
            if(cnt==-1)
                {cout<<"-1"<<endl;continue;}
            for(i=0;i<n;i++)
                node[i].vis=false;
            sort(node,node+n,cmp);
            bool flag;
            for(i=0;i<n&&cnt>=0;i++)
            {
                if(!node[i].vis)
                for(j=0;j<n;j++)
                {
                    if(!node[j].vis)
                    {
                        if(node[j].l<=node[i].r)
                        {
                            node[j].vis=true;
                            flag=true;
                        }
                        else break;
                    }
                }
                if(flag)
                    cnt++;
                flag=0;
            }
            cout<<cnt<<endl;
        }
        return 0;
    }
  • 相关阅读:
    解释JUnit中@BeforeClass和@AfterClass标注的方法必须是static的,而在TestNg不必
    总结TestNg与JUnit的异同
    FitNesseRoot/ErrorLogs目录下可查看fitnesse输出日志
    项目构建工具ant的使用
    用插件maven-surefire-report-plugin生成html格式测试报告
    fitnesse生成的FitNesseRoot路径问题
    fitnesse管理引进的jar包
    简要总结selenium四个工具组
    selenium 2 设置浏览器安装路径
    磁盘IO
  • 原文地址:https://www.cnblogs.com/crazyacking/p/3728279.html
Copyright © 2011-2022 走看看