zoukankan      html  css  js  c++  java
  • 组合数学

    Holding Bin-Laden Captive!

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 15064    Accepted Submission(s): 6750


    Problem Description
    We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
    “Oh, God! How terrible! ”



    Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
    Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
    “Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
    You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
     
    Input
    Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
     
    Output
    Output the minimum positive value that one cannot pay with given coins, one line for one case.
     
    Sample Input
    3
    0 0
     
    Sample Output
    4
     
    Author
    lcy
     
     

    Mean: 

     略

    analyse:

     经典的母函数的运用题。

    该模板是个数有限制的时候的模板。

    Time complexity:O(n^3)

    Source code:

    // Memory   Time
    // 1347K     0MS
    // by : Snarl_jsb
    // 2014-09-18-15.35
    #include<algorithm>
    #include<cstdio>
    #include<cstring>
    #include<cstdlib>
    #include<iostream>
    #include<vector>
    #include<queue>
    #include<stack>
    #include<map>
    #include<string>
    #include<climits>
    #include<cmath>
    #define N 1000010
    #define LL long long
    using namespace std;
    
    int cnt[4],c1[123456],c2[123456];
    int main()
    {
        ios_base::sync_with_stdio(false);
        cin.tie(0);
    //    freopen("C:\Users\ASUS\Desktop\cin.cpp","r",stdin);
    //    freopen("C:\Users\ASUS\Desktop\cout.cpp","w",stdout);
        int val[4]={0,1,2,5};
        int x,y,z;
        while(cin>>x>>y>>z&&(x+y+z))
        {
            int sum=x+2*y+5*z;
            memset(c1,0,sizeof(c1));
            memset(c2,0,sizeof(c2));
            int cnt[4]={0,x,y,z};
            for(int i=0;i<=cnt[1];++i)
            {
                c1[i]=1;
            }
            for(int i=2;i<=3;++i)
            {
                for(int j=0;j<=sum;++j)
                {
                    for(int k=0;k<=cnt[i];k++)
                        c2[k*val[i]+j]+=c1[j];
                }
                for(int j=0;j<=sum;++j)
                {
                    c1[j]=c2[j];
                    c2[j]=0;
                }
            }
            for(int i=1;i<=sum+1;++i)
                if(!c1[i])
                {
                    cout<<i<<endl;
                    break;
                }
        }
        return 0;
    }
    

      

  • 相关阅读:
    1 2 3 4 5 6 7 8 9 = 81 在19之间添加加减乘除号,使等式成立
    D3D 模板缓存的创建过程
    visual studio 引用lib
    ASP.NET Core MVC 打造一个简单的图书馆管理系统 (修正版)(一) 基本模型以及数据库的建立
    ViewModel、ViewData、ViewBag、TempData、Session之间的区别和各自的使用方法
    ASP.NET Core MVC 打造一个简单的图书馆管理系统 (修正版)(二)数据库初始化、基本登录页面以及授权逻辑的建立
    在visual studio code和visual studio中编写TypeScript文件自动生成JavaScript文件
    605. 种花问题
    53. 最大子数组和
    47. 全排列 II
  • 原文地址:https://www.cnblogs.com/crazyacking/p/3979539.html
Copyright © 2011-2022 走看看