zoukankan      html  css  js  c++  java
  • 后缀数组(模板题)

    Language:
    Long Long Message
    Time Limit: 4000MS   Memory Limit: 131072K
    Total Submissions: 21228   Accepted: 8708
    Case Time Limit: 1000MS

    Description

    The little cat is majoring in physics in the capital of Byterland. A piece of sad news comes to him these days: his mother is getting ill. Being worried about spending so much on railway tickets (Byterland is such a big country, and he has to spend 16 shours on train to his hometown), he decided only to send SMS with his mother.

    The little cat lives in an unrich family, so he frequently comes to the mobile service center, to check how much money he has spent on SMS. Yesterday, the computer of service center was broken, and printed two very long messages. The brilliant little cat soon found out:

    1. All characters in messages are lowercase Latin letters, without punctuations and spaces.
    2. All SMS has been appended to each other – (i+1)-th SMS comes directly after the i-th one – that is why those two messages are quite long.
    3. His own SMS has been appended together, but possibly a great many redundancy characters appear leftwards and rightwards due to the broken computer.
    E.g: if his SMS is “motheriloveyou”, either long message printed by that machine, would possibly be one of “hahamotheriloveyou”, “motheriloveyoureally”, “motheriloveyouornot”, “bbbmotheriloveyouaaa”, etc.
    4. For these broken issues, the little cat has printed his original text twice (so there appears two very long messages). Even though the original text remains the same in two printed messages, the redundancy characters on both sides would be possibly different.

    You are given those two very long messages, and you have to output the length of the longest possible original text written by the little cat.

    Background:
    The SMS in Byterland mobile service are charging in dollars-per-byte. That is why the little cat is worrying about how long could the longest original text be.

    Why ask you to write a program? There are four resions:
    1. The little cat is so busy these days with physics lessons;
    2. The little cat wants to keep what he said to his mother seceret;
    3. POJ is such a great Online Judge;
    4. The little cat wants to earn some money from POJ, and try to persuade his mother to see the doctor :(

    Input

    Two strings with lowercase letters on two of the input lines individually. Number of characters in each one will never exceed 100000.

    Output

    A single line with a single integer number – what is the maximum length of the original text written by the little cat.

    Sample Input

    yeshowmuchiloveyoumydearmotherreallyicannotbelieveit
    yeaphowmuchiloveyoumydearmother
    

    Sample Output

    27

     

    Mean: 

     给你两个字符串s1和s2,输出这两个字符串的最长公共子串长度。

    analyse:

    求最长公共子序列的方法很多,这里用后缀数组实现。

    后缀数组怎么求最长公共子序列呢?

    在后缀数组中,height数组:height[i]保存的是字典序排名相邻的两个后缀子串的最长公共前缀。

    将s2接到s1后面,然后中间用一个未出现的字符隔开,再求height数组。

    这两个字符串的最长公共子串必定存在于合并后的S串的最长公共前缀之中。

    只需要寻找分别来自于s1串和来自于s2串的两个前缀的height的最大值,即得答案。

    Time complexity:O(nlogn)

    Source code:

    /*
    * this code is made by crazyacking
    * Verdict: Accepted
    * Submission Date: 2015-05-09-21.22
    * Time: 0MS
    * Memory: 137KB
    */
    #include <queue>
    #include <cstdio>
    #include <set>
    #include <string>
    #include <stack>
    #include <cmath>
    #include <climits>
    #include <map>
    #include <cstdlib>
    #include <iostream>
    #include <vector>
    #include <algorithm>
    #include <cstring>
    #define  LL long long
    #define  ULL unsigned long long
    using namespace std;
    const int MAXN=100010<<1;
    //以下为倍增算法求后缀数组
    int wa[MAXN],wb[MAXN],wv[MAXN],Ws[MAXN];
    int cmp(int *r,int a,int b,int l)
    {return r[a]==r[b]&&r[a+l]==r[b+l];}
    /**< 传入参数:str,sa,len+1,ASCII_MAX+1 */
    void da(const char *r,int *sa,int n,int m)
    {
         int i,j,p,*x=wa,*y=wb,*t;
         for(i=0; i<m; i++) Ws[i]=0;
         for(i=0; i<n; i++) Ws[x[i]=r[i]]++;
         for(i=1; i<m; i++) Ws[i]+=Ws[i-1];
         for(i=n-1; i>=0; i--) sa[--Ws[x[i]]]=i;
         for(j=1,p=1; p<n; j*=2,m=p)
         {
               for(p=0,i=n-j; i<n; i++) y[p++]=i;
               for(i=0; i<n; i++) if(sa[i]>=j) y[p++]=sa[i]-j;
               for(i=0; i<n; i++) wv[i]=x[y[i]];
               for(i=0; i<m; i++) Ws[i]=0;
               for(i=0; i<n; i++) Ws[wv[i]]++;
               for(i=1; i<m; i++) Ws[i]+=Ws[i-1];
               for(i=n-1; i>=0; i--) sa[--Ws[wv[i]]]=y[i];
               for(t=x,x=y,y=t,p=1,x[sa[0]]=0,i=1; i<n; i++)
                     x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
         }
         return;
    }
    int sa[MAXN],Rank[MAXN],height[MAXN];
    /**< str,sa,len */
    void calheight(const char *r,int *sa,int n)
    {
         int i,j,k=0;
         for(i=1; i<=n; i++) Rank[sa[i]]=i;
         for(i=0; i<n; height[Rank[i++]]=k)
               for(k?k--:0,j=sa[Rank[i]-1]; r[i+k]==r[j+k]; k++);
         // Unified
         for(int i=n;i>=1;--i) ++sa[i],Rank[i]=Rank[i-1];
    }

    char s1[MAXN],s2[MAXN];
    int main()
    {
         while(~scanf("%s%s",s1,s2))
         {
               int l1=strlen(s1);
               strcat(s1,"{");
               strcat(s1,s2);
               int len=strlen(s1);
               for(int i=0;i<len;++i) s1[i]-='a'-1;
               da(s1,sa,len+1,30);
               calheight(s1,sa,len);
               int ans=0;
               for(int i=2;i<=len;++i)
                     if((sa[i-1]-1<l1 && sa[i]-1>l1) || (sa[i-1]-1>l1 && sa[i]-1<l1))
                           ans=max(ans,height[i]);
               printf("%d ",ans);
         }
         return 0;
    }
  • 相关阅读:
    当你不知道今天星期几,不妨在编辑器写下这段代码
    自定义注解!绝对是程序员装逼的利器!!
    什么是可串行化MVCC
    Jetpack新成员,一篇文章带你玩转Hilt和依赖注入
    连接真机开发安卓(Android)移动app MUI框架 添加购物车等——混合式开发(四)
    从前世今生聊一聊,大厂为啥亲睐时序数据库
    工作五年,面试官说我只会CRUD!竟然只给我10K!
    bootstrap知识总结
    数据处理的两个基本问题05 零基础入门学习汇编语言42
    转移指令的原理02 零基础入门学习汇编语言44
  • 原文地址:https://www.cnblogs.com/crazyacking/p/3991478.html
Copyright © 2011-2022 走看看