zoukankan      html  css  js  c++  java
  • hdu 2594 Simpsons’ Hidden Talents(kmp)

    http://acm.hdu.edu.cn/showproblem.php?pid=2594

    Problem Description
    Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had. Marge: Yeah, what is it? Homer: Take me for example. I want to find out if I have a talent in politics, OK? Marge: OK. Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton Marge: Why on earth choose the longest prefix that is a suffix??? Homer: Well, our talents are deeply hidden within ourselves, Marge. Marge: So how close are you? Homer: 0! Marge: I’m not surprised. Homer: But you know, you must have some real math talent hidden deep in you. Marge: How come? Homer: Riemann and Marjorie gives 3!!! Marge: Who the heck is Riemann? Homer: Never mind. Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
     
    Input
    Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
     
    Output
    Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0. The lengths of s1 and s2 will be at most 50000.
     
    Sample Input
    clinton homer riemann marjorie
     
    Sample Output
    0 rie 3
     
    思路:next数组的应用
    #include<iostream>
    using namespace std;
    char str1[50010],str2[50010];
    int next[50010];
    void get_next(char *str)
    {
        int len=strlen(str);
        int i=0,j=-1;
        next[0]=-1;
        while(i<len)
        {
            if(j==-1||str[i]==str[j])
            {
                i++;
                j++;
                next[i]=j;
            }
            else
                j=next[j];
        }
    }
    
    int match_str(int len1,int len2)
    {
        int i=0,j=0;
        while(i<len2)
        {
            if(j==-1||str1[j]==str2[i])
            {
                i++;
                j++;
            }
            else
                j=next[j];
        }
        return j;
    }
    int main()
    {
        while(gets(str1))
        {
            gets(str2);
            get_next(str1);
            int len1=strlen(str1);
            int len2=strlen(str2);
            int n=match_str(len1,len2);
            int i;
            for(i=0;i<n;i++)
                putchar(str1[i]);
            if(n)
                putchar(' ');
            printf("%d\n",n);
        
        }
        return 0;
    }
  • 相关阅读:
    玩转持续化集成之Jenkins
    常用的免费移动应用测试框架推荐
    没有学过功夫能否练神功
    Android APP性能测试(下)
    Android APP性能测试(上)
    python-mongodb简单封装
    python使用协程完成批量模拟支付
    python多进程完成模拟支付
    python多线程完成模拟支付请求
    python-自动登录禅道
  • 原文地址:https://www.cnblogs.com/crazyapple/p/2841655.html
Copyright © 2011-2022 走看看