zoukankan      html  css  js  c++  java
  • 4.2.5 Red and Black

    Problem Description
    There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

    Write a program to count the number of black tiles which he can reach by repeating the moves described above.
     

    Input
    The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

    There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

    '.' - a black tile
    '#' - a red tile
    '@' - a man on a black tile(appears exactly once in a data set)
     

    Output
    For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
     

    Sample Input
    6 9
    ....#.
    .....#
    ......
    ......
    ......
    ......
    ......
    #@...#
    .#..#.
    11 9
    .#.........
    .#.#######.
    .#.#.....#.
    .#.#.###.#.
    .#.#..@#.#.
    .#.#####.#.
    .#.......#.
    .#########.
    ...........
    11 6
    ..#..#..#..
    ..#..#..#..
    ..#..#..###
    ..#..#..#@.
    ..#..#..#..
    ..#..#..#..
    7 7
    ..#.#..
    ..#.#..
    ###.###
    ...@...
    ###.###
    ..#.#..
    ..#.#..
    0 0
     

    Sample Output
    45
    59
    6
    13

    思路:数据范围很小啊,dfs即可,注意数组的清零

    #include <cstdio>
    #include <cstring>
    using namespace std;
    
    bool vis[22][22];
    char map[22][22];
    int n,m,ax,ay,ans;
    const int dx[]={0,0,1,-1};
    const int dy[]={1,-1,0,0};
    
    void dfs(int x,int y)
    {
    for (int k=0;k<4;k++)
    {
    	int xx=x+dx[k];
    	int yy=y+dy[k];
    	if (map[xx][yy]=='.' && vis[xx][yy]==false 
    		&& xx>=0 && yy>=0 && xx<n && y<m
    		)
    	{
    		ans++;
    		vis[xx][yy]=true;
    		dfs(xx,yy);
    	}
    }
    }
    
    void init ()
    {
      while(scanf("%d%d",&m,&n)!=EOF)
      {
    	  ans=0;
    	  if (n==0 && m==0) break;
    	  memset(vis,false,sizeof(vis));
    	  memset(map,'\0',sizeof(map));
    	//  printf("TEST!!!\n");
    	  for (int i=0;i<n;i++)
    	  {
    		  scanf("%s",map[i]);
    		  for (int j=0;j<m;j++)
    			  if (map[i][j]=='@')
    			  {
    				  ax=i;
    				  ay=j;
    			  }
    	  }
    //	  printf("ax:%d ay:%d\n",ax,ay);
    	  dfs(ax,ay);
    //	  printf("ans::%d\n",ans+1);
    	  printf("%d\n",ans+1);
    	}
    }
    
    int main ()
    {
    init();
    return 0;
    }
    
  • 相关阅读:
    留言板
    文件操作1
    JQUERY与JS的区别
    PHP 练习租房
    PHP 投票练习
    PHP,单项查询及多项查询
    PHP 增删改查 import!!
    PHP 数据访问
    PHP 对象及其三大特性
    正则表达式和数组
  • 原文地址:https://www.cnblogs.com/cssystem/p/2827254.html
Copyright © 2011-2022 走看看