zoukankan      html  css  js  c++  java
  • CSUOJ 1007 矩形着色

    Description

    Danni想为屏幕上的一个矩形着色,但是她想到了一个问题。当点击鼠标以后电脑是如何判断填充的区域呢?

    现在给你一个平面直角坐标系,其中有一个矩形和一个点,矩形的四条边均是平行于x轴或y轴的。请你判断这个点相对于矩形的位置,即在矩形内,在矩形上,还是在矩形外?

    Input

    第一行只有一个整数T,(T < 150),代表共有T种情况。

    接下对于每种情况,均有两行数据:

    第一行有两个整数Px Py,以空格分隔,代表点的坐标(Px,Py).

    第二行有四个整数Ax Ay Bx By,以空格分隔,代表矩形左下角的坐标(Ax,Ay)和右上角的坐标(Bx,By).

    所有的坐标均为区间[0,100]内的整数,且Ax<Bx,Ay<By

    Output

    对于每种情况仅输出一行:

    1. 如果点在矩形外部,请输出”Outside”
    2. 如果点正好在矩形的边上,请输出”On”
    3. 如果点在矩形内部,请输出”Inside”所有输出都不包含引号。

    Sample Input

    3
    38 7
    30 7 52 66
    55 1
    9 13 54 84
    74 67
    73 66 76 68
    

    Sample Output

    On
    Outside
    Inside
    

    Hint


    根据边缘的坐标进行判断

    #include<stdio.h>
    #include<string>
    #include<string.h>
    #include<algorithm>
    #include<iostream>
    using namespace std;
    int main()
    {
    	int T;
    	int Ax, Ay, Bx, By,Px,Py;
    	while (~scanf("%d", &T))
    	{
    		while (T--)
    		{
    			scanf("%d%d", &Px, &Py);
    			scanf("%d%d%d%d", &Ax, &Ay, &Bx, &By);
    			if (Px == Ax || Px == Bx)
    			{
    				if (Py >= Ay&&Py <= By)
    					cout << "On" << endl;
    				else
    					cout << "Outside" << endl;
    				continue;
    			}
    			else if (Py == Ay || Py == By)
    			{
    				if (Px >= Ax&&Px <= Bx)
    					cout << "On" << endl;
    				else
    					cout << "Outside" << endl;
    				continue;
    			}
    			else if (Px >= Ax&&Px <= Bx&&Py >= Ay&&Py <= By)
    			{
    				cout << "Inside" << endl;
    			}
    			else
    				cout << "Outside" << endl;
    		}
    	}
    	return 0;
    }
    /**********************************************************************
    	Problem: 1007
    	User: leo6033
    	Language: C++
    	Result: AC
    	Time:8 ms
    	Memory:2024 kb
    **********************************************************************/
    

  • 相关阅读:
    cli create ssl certkey
    开启HSTS让浏览器强制跳转HTTPS访问
    Down State Flush Feature
    tasklist、taskkill命令使用
    findstr 命令使用
    【批处理学习笔记】第十一课:常用DOS命令(1)
    【批处理学习笔记】第十课:批处理符号(3)
    【批处理学习笔记】第九课:批处理符号(2)
    【批处理学习笔记】第八课:批处理符号(1)
    【批处理学习笔记】第七课:简单的批处理命令(6)
  • 原文地址:https://www.cnblogs.com/csu-lmw/p/9124449.html
Copyright © 2011-2022 走看看