zoukankan      html  css  js  c++  java
  • POJ1144-NetWork(无向图的割顶)

    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 16142   Accepted: 7305

    Description

    A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is 
    possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure 
    occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

    Input

    The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated 
    by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

    Output

    The output contains for each block except the last in the input file one line containing the number of critical places.

    Sample Input

    5
    5 1 2 3 4
    0
    6
    2 1 3
    5 4 6 2
    0
    0

    Sample Output

    1
    2

    Hint

    You need to determine the end of one line.In order to make it's easy to determine,there are no extra blank before the end of each line.

    Source

    无向图的割顶基础题;

    代码为:

    #include<bits/stdc++.h>
    using namespace std;
    #define MAXp 109

    #define MAXe 10000

    struct Edge{
        int v;
        int next;   
    } edge[MAXe*2];

    int head[MAXp],dfn[MAXp],low[MAXp],c,ts,r,cnt;
    bool flag[MAXp];
     
    void addEdge(int u,int v)
    {
        edge[c].v=v;
        edge[c].next=head[u];
        head[u]=c;
        c++;
    }
     
    void dfs(int p,int pre)
    {
        int i,v;
        dfn[p]=low[p]=++ts;
        for(i=head[p];i!=-1;i=edge[i].next)
        {
            v=edge[i].v; 
            if(!dfn[v])
            {
                dfs(v,p);
                low[p]=min(low[p],low[v]);
                if(p!=r&&dfn[p]<=low[v])  flag[p]=true;   //一个割点属于多个点双连通分量,需要防止重复计算 
                else if(p==r) cnt++;
            }
            else if(v!=pre)  low[p]=min(low[p],dfn[v]);
        }
    }
     
    int main()
    {
        int n,u,i,tmp,ans;
        string str;
        while(cin>>n && n!=0)
        {
            memset(head,-1,sizeof(head));
            c=0;                       
            while(cin>>u && u!=0)     
            {
                getline(cin,str);  
                tmp=0;           
                for(i=1;i<str.length();i++) 
                {
                    if(str[i]>='0'&&str[i]<='9')  tmp=tmp*10+(str[i]-48);    
                    else
                    {                 
                        addEdge(u,tmp);
                        addEdge(tmp,u); 
                        tmp=0;
                    }                     
                }
                addEdge(u,tmp);
                addEdge(tmp,u);                      
            }
            ts=cnt=0;
            r=1;
            memset(dfn,0,sizeof(dfn));
            memset(flag,false,sizeof(flag));
            dfs(r,-1);
            if(cnt>1) ans=1;
            else ans=0;         
            for(i=1;i<=n;i++) if(flag[i]==true) ans++;       
            cout<<ans<<endl;                    
        } 
        return 0; 
    }

  • 相关阅读:
    manjaro更换源
    质子重离子快速蒙卡MCsquare在ubuntu-20.04下的安装
    虚拟机硬盘容量不够如何解决
    《收获,不止oracle》读书笔记-未完
    Jenkins 性能:如何避免陷阱、诊断问题和扩展
    这是一个人工智能,你有什么紧急情况?
    人工智能:备忘单
    AI 变得越来越聪明、越来越快。这创造了我们无法回答的棘手问题
    什么是人工智能?你需要知道的关于人工智能的一切
    jenkins构建成功为何显示蓝色
  • 原文地址:https://www.cnblogs.com/csushl/p/9386524.html
Copyright © 2011-2022 走看看