zoukankan      html  css  js  c++  java
  • HDU-1022



    As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2. 
      
    InputThe input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input. 
    OutputThe output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output. 
    Sample Input
    3 123 321
    3 123 312
    Sample Output
    Yes.
    in
    in
    in
    out
    out
    out
    FINISH
    No.
    FINISH
    
    
            
      
    For the first Sample Input, we let train 1 get in, then train 2 and train 3.
    So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
    In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
    Now we can let train 3 leave.
    But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
    So we output "No.".

    题解:用栈来判断,序列 1 元素进栈,如果栈非空且栈顶元素和序列 2 当前元素相同,出栈;否则,序列 1 元素继续进栈。过程中可以用数组记录火车是进栈还是出栈。

    AC代码为:

    #include<stdio.h>
    #include<string.h>
    int main()
    {
    int num,q,p,o,in[20],out[20];
    char iin[20],oout[20];
    while(scanf("%d%s%s",&num,iin,oout)!=EOF)
    {
    int flag[20]={0};
    int station[20]={0};

    for(int i=0;i<num;i++)
    {
    in[i]=iin[i]-'0';
    out[i]=oout[i]-'0';
    }

    q=p=0;
    o=0;

    for(int i=0;i<num;i++)
    {
    station[q]=in[i];
    q++;
    o++;
    while(station[q-1]==out[p])
    {

    q--;
    p++;
    flag[o]=1;
    o++;

    }
    }

    if(p==num)
    {
    printf("Yes. ");
    for(int i=0;i<o;i++)
    {
    if(flag[i]==0) 
    printf("in ");
    else 
    printf("out ");
    }
    }

    else 
    printf("No. ");

    printf("FINISH ");
    }
    return 0;


  • 相关阅读:
    asp.net webform 不显示__doPostBack的原因及某种解决方法
    sqlserver查询父子级关系
    使用gitblit搭建自己的代码存储仓库
    c# 十进制转二、八、十六进制
    asp.net webapi 返回json结果的方法
    每天CSS学习之text-indent
    每天CSS学习之text-decoration
    每天CSS学习之text-align
    每天CSS学习之line-height
    每天CSS学习之letter-spacing
  • 原文地址:https://www.cnblogs.com/csushl/p/9386629.html
Copyright © 2011-2022 走看看