zoukankan      html  css  js  c++  java
  • UVA-10815


    Andy, 8, has a dream - he wants to produce hisvery own dictionary. This is not an easy task forhim, as the number of words that he knows is,well, not quite enough. Instead of thinking up allthe words himself, he has a briliant idea. Fromhis bookshelf he would pick one of his favouritestory books, from which he would copy out allthe distinct words. By arranging the words inalphabetical order, he is done! Of course, it isa really time-consuming job, and this is where acomputer program is helpful.You are asked to write a program that listsall the different words in the input text. In thisproblem, a word is defined as a consecutive sequenceof alphabets, in upper and/or lower case.Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE.For example, words like “Apple”, “apple” or “APPLE” must be considered the same.InputThe input file is a text with no more than 5000 lines. An input line has at most 200 characters. Inputis terminated by EOF.OutputYour output should give a list of different words that appears in the input text, one in a line. Thewords should all be in lower case, sorted in alphabetical order. You can be sure that he number ofdistinct words in the text does not exceed 5000.Sample InputAdventures in DisneylandTwo blondes were going to Disneyland when they came to a fork in theroad. The sign read: "Disneyland Left."So they went home.Sample Outputaadventuresblondescamedisneylandforkgoinghomeinleftreadroadsignso

    题意:题目大意:给出一个文本,找出所有不同的单词。按字典序升序输出。Ps:单词不区分大小写。



    题解;用到set<>容器(单词部分大小写,先将其转换为小写);用到很多函数;

    AC:

    #include <iostream>
    #include <string>
    #include <algorithm>
    #include <set>
    #include <sstream>
    using namespace std;


    int main()
    {
        string str, buf;
        set<string>a;
        while(cin>>str)
        {
            for(int i=0;i<str.length();i++)
            {
                if(isalpha(str[i]))
                    str[i] = tolower(str[i]);
                else
                    str[i] = ' ';
            }
            stringstream str2(str);
            while(str2 >> buf)
            {
                a.insert(buf);
            }


        }
            for(set<string>::iterator it= a.begin();it!=a.end();it++)
            {
                cout<<*it<<endl;
            }
        
        return 0;
    }



  • 相关阅读:
    多线程简略版
    vue组件,vue补充和总结,JS循环遍历和加减运算、类型转换补充
    表单、条件、循环指令,分隔符,前端数据库,过滤器,计算属性,监听属性,冒泡排序
    vue基本语法 JS补充
    VUE框架
    跨站请求伪造(csrf),django的settings源码剖析,django的auth模块
    cookie和session django中间件
    多对多第三张表的创建方式 和 forms组件的使用
    golang之 Array(数组)
    变量,数据类型,运算符,流程控制
  • 原文地址:https://www.cnblogs.com/csushl/p/9386631.html
Copyright © 2011-2022 走看看