zoukankan      html  css  js  c++  java
  • HDU1217-Arbitrage(乘法最短路)

    Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

    Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

    Input

    The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
    Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n. 

    Output

    For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No". 

    Sample Input

    3
    USDollar
    BritishPound
    FrenchFranc
    3
    USDollar 0.5 BritishPound
    BritishPound 10.0 FrenchFranc
    FrenchFranc 0.21 USDollar
    
    3
    USDollar
    BritishPound
    FrenchFranc
    6
    USDollar 0.5 BritishPound
    USDollar 4.9 FrenchFranc
    BritishPound 10.0 FrenchFranc
    BritishPound 1.99 USDollar
    FrenchFranc 0.09 BritishPound
    FrenchFranc 0.19 USDollar
    
    0

    Sample Output

    Case 1: Yes
    Case 2: No

    题解:

    这题是寻找是否存在一种钱币使得交换一圈后可以盈利。就是以任意为起点,找一个终点使得d[i][j]*d[j][i]>1.0即可;

    就是Folyd处理,然后判断即可,水题;

    AC代码为:

    //水题,乘法最短路,格式真的。。。 
    #include<bits/stdc++.h>
    using namespace std;
    double val,dis[50][50];
    int n,m,temp,Cas=1;
    map<string,int> mp;

    void Floyd()
    {
        for(int k=1;k<=n;k++)
        {
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=n;j++)
                    dis[i][j]=max(dis[i][j],dis[i][k]*dis[k][j]);
            }
        }
    }

    int main()
    {
        ios::sync_with_stdio(false);
        while(cin>>n , n)
        {   
            string s1,s2;
            temp=1; mp.clear();
            memset(dis,0,sizeof dis);
            for(int i=1;i<=n;i++) 
            {
                cin>>s1;
                mp[s1]=temp++;
            }
            cin>>m;
            for(int i=1;i<=m;i++)
            {
                cin>>s1>>val>>s2;
                dis[mp[s1]][mp[s2]]=val;    
            }
            if(n==1 && dis[1][1]>1.0) 
            {
                cout<<"Case "<<Cas++<<": "<<"Yes"<<endl;
                //cout<<endl;
                continue;   
            }
            Floyd();
            bool flag=false;
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=n;j++)
                    if(i==j) continue;
                    else if(dis[i][j]*dis[j][i]>1.0)
                    {
                        flag=true;
                        break;
                    }
                if(flag) break;
            }
            if(flag)  cout<<"Case "<<Cas++<<": "<<"Yes"<<endl;
            else  cout<<"Case "<<Cas++<<": "<<"No"<<endl;
            //cout<<endl;
        }
        
        return 0;
    }

  • 相关阅读:
    centos7 Nginx1.14+php7+mysql5.7 以及 centos7 Apache2.4+PHP7+mysql 安装 Linux 配置 composer 以及Python2.7升级到3.7
    微信遇到的几个小问题
    前段mui框架初识
    关于百度编辑器设置默认行间距段间距
    call与apply 以及闭包
    随笔日记2018 4.10 关于多选框
    关于JVM中的两个Survivor区
    (转)Struts2的工作原理
    (转)struts2的执行流程、工作原理
    (转)最大乘积分析(切绳子)
  • 原文地址:https://www.cnblogs.com/csushl/p/9386766.html
Copyright © 2011-2022 走看看