zoukankan      html  css  js  c++  java
  • Argus(ZOJ Problem Set 2212)(优先队列)

    Argus 分享至QQ空间 去爱问答提问或回答

    时间限制(普通/Java):1000MS/3000MS     运行内存限制:65536KByte
    总提交: 3            测试通过: 2

    描述

     

    A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.
     

    Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes."
    Query-2: "Return the average temperature measured on each floor over the past 10 minutes."


    We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.

    For the Argus, we use the following instruction to register a query:
     

    Register Q_num Period


    Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds.

    Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.
     

     

    输入

     

    The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#".

    The second part is your task. This part contains only one line, which is one positive integer K (<= 10000).
     

     

    输出

    You should output the Q_num of the first K queries to return the results, one number per line.

    样例输入

     

    Register 2004 200
    Register 2005 300
    #
    5
    

     

    样例输出

     

    2004
    2005
    2004
    2004
    2005
    

     

    题目来源

    Beijing 2004

    题目上传者

    crq


    #include <iostream>
    #include <string>
    #include <queue>
    using namespace std;
    
    struct Instrut
    {
        int id;
        double ReturnTime; 
        double period;
        Instrut(int i, double p):id(i), ReturnTime(p), period(p){}
    
    };
    
    bool operator < (const Instrut& x, const Instrut& y)
    {
        if(x.ReturnTime != y.ReturnTime)
            return x.ReturnTime > y.ReturnTime;
        return x.id > y.id;
    }
    
    int main()
    {
        string str;
        int k, id, period;
        priority_queue<Instrut> que;
        for(int i = 0; cin >> str; ++i)
        {
            if(str == "#") break;
            else
                cin >> id >> period;
            Instrut tmp(id, period);
            que.push(tmp);
        }
        cin >> k;
        while(k--)
        {
            Instrut tmp = que.top();
            que.pop();
            cout << tmp.id << endl;
            tmp.ReturnTime += tmp.period;
            que.push(tmp);
        }
        return 0;
    }



  • 相关阅读:
    封装aixos拦截器
    vue路由传参的三种基本方式
    vue里的路由钩子
    箭头函数特点
    webstorm激活码
    vue-cli2使用less
    vue-cli2使用rem适配
    XfZGkvBaeh
    python解析excel中图片+提取图片
    python解析谷歌在线表格链接,转化为数组形式,图片转化为链接
  • 原文地址:https://www.cnblogs.com/cszlg/p/2910444.html
Copyright © 2011-2022 走看看