zoukankan      html  css  js  c++  java
  • HDU 1213 How Many Tables(并查集)

    How Many Tables

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5194    Accepted Submission(s): 2452


    Problem Description
    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
     

    Input
    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
     

    Output
    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
     

    Sample Input
    2 5 3 1 2 2 3 4 5 5 1 2 5
     

    Sample Output
    2 4
     

    Author
    Ignatius.L
     

    第一次使用Find_Set的合并集合的方法,一次提交成功,内心受到小小的鼓舞。^_^

    AC code:

    #include <iostream>
    using namespace std;
    
    const int N=1001;
    int flag[N];
    
    int Find_Set(int x)
    {
        if(x!=flag[x])
        {
            flag[x]=Find_Set(flag[x]);
        }
        return flag[x];
    }
    
    int main()
    {
        int t,m,n,i,j,a,b,A,B,num;
        cin>>t;
        while(t--)
        {
            cin>>n>>m;
            for(i=1;i<=n;i++) flag[i]=i;
            num=n;
            for(i=1;i<=m;i++)
            {
                cin>>A>>B;
                a=Find_Set(A);
                b=Find_Set(B);
                if(a>b)
                {
                    flag[a]=b;
                    num--;
                }
                else if(a<b)
                {
                    flag[b]=a;
                    num--;
                }
            }
            cout<<num<<endl;
        }
        return 0;
    }
    


  • 相关阅读:
    ABP框架插件开发
    ionic 向路由中的templateUrl(模板页)传值
    EFT4 生成实体类
    mvc 下的 signalR使用小结
    利用javascript实现页面截图
    linux定时任务php
    PHPCMSV9的CKEDITOR编辑器增加行距
    上传网站后建议执行:chown www:www -R /path/to/dir 对网站目录进行权限设置,/path/to/dir替换为你网站目录。
    centOS7下安装GUI图形界面
    虚拟机中的Linux安装VMware Tools的方法
  • 原文地址:https://www.cnblogs.com/cszlg/p/2910514.html
Copyright © 2011-2022 走看看