zoukankan      html  css  js  c++  java
  • HDOJ Prime Ring Problem (深度优先搜索)

    Prime Ring Problem

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 11488    Accepted Submission(s): 5194


    Problem Description
    A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

    Note: the number of first circle should always be 1.


     

    Input
    n (0 < n < 20).
     

    Output
    The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

    You are to write a program that completes above process.

    Print a blank line after each case.
     

    Sample Input
    6 8
     

    Sample Output
    Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
     

    Source
     


    #include <iostream>
    #include <cstring>
    
    using namespace std;
    
    int n,j,k=1,visit[20],a[20]={1};
    int prime[38]={0,0,1,1,0,1,0,1,0,0,
    	       0,1,0,1,0,0,0,1,0,1,
    	       0,0,0,1,0,0,0,0,0,1,
    	       0,1,0,0,0,0,0,1}; 
    			   
    void DFS(int m)
    {
    	if(m==n && prime[1+a[n-1]])
    	{
    		for(int i=0;i<n-1;i++)
    			cout<<a[i]<<" ";
    		cout<<a[n-1]<<endl;	
    	}
    	
    	else
    	{
    		for(int i=2;i<=n;i++)
    		{
    			if(prime[i+a[m-1]] && !visit[i])
    			{
    				a[m]=i;
    				visit[i]=1;
    				DFS(m+1);
    				visit[i]=0;	
    			}	
    		}	
    	}	
    }
    
    int main()
    {	
    	while(cin>>n)
    	{
    		memset(visit,0,sizeof(visit));
    		cout<<"Case "<<k++<<":"<<endl;
    		DFS(1);
    		cout<<endl;
    	}
    	
    	return 0;	
    }


  • 相关阅读:
    OpenCV 最小二乘拟合方法求取直线倾角
    BFS-hdu-4101-Ali and Baba
    手机安全卫士开发系列(1)——功能列表
    【Linux常用工具】1.1 diff命令的三种格式
    手机安全卫士开发系列(2)——splash界面
    Ruby学习笔记(二)
    jQuery Animation实现CSS3动画
    HDU2699+Easy
    android中解析文件的三种方式
    查找某元素
  • 原文地址:https://www.cnblogs.com/cszlg/p/2910528.html
Copyright © 2011-2022 走看看