zoukankan      html  css  js  c++  java
  • HDUOJ 2056 Rectangles (几何计算问题)

    Rectangles

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 7889    Accepted Submission(s): 2538


    Problem Description
    Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .
     

    Input
    Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).
     

    Output
    Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.
     

    Sample Input
    1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00 5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50
     

    Sample Output
    1.00 56.25
     
    #include <algorithm>
    #include <iostream>
    using namespace std;
    int main()
    {
    	double x[4],y[4],area;
    	int i,j;
    	while(cin>>x[0]>>y[0]>>x[1]>>y[1]>>x[2]>>y[2]>>x[3]>>y[3])
    	{
    		//判断两个矩形是否没有公共部分
    		for(i=0;i<4;i+=2)
    		{
    			if(x[i]>x[i+1]) swap(x[i],x[i+1]);
    			if(y[i]>y[i+1]) swap(y[i],y[i+1]);
    		}
    		if(x[2]>=x[1]||x[0]>=x[3]||y[2]>=y[1]||y[0]>=y[3]) area=0;
    		//有公共部分时计算面积
    		else
    		{
    			/*排序,排序后x[2]-x[1]即是公共部分的长,
    			y[2]-y[1]即是公共部分的高,注意公共部分是矩形*/
    			for(i=0;i<4;i++)
    			{
    				for(j=0;j<3-i;j++)
    				{
    					if(x[j]>x[j+1])
    						swap(x[j],x[j+1]);
    					if(y[j]>y[j+1])
    						swap(y[j],y[j+1]);
    				}
    			}
    
    			area=(x[2]-x[1])*(y[2]-y[1]);
    		}
    		printf("%.2lf\n",area);
    	}
    	return 0;
    }


  • 相关阅读:
    《剑指Offer》题目:跳台阶
    《剑指Offer》题目:变态跳台阶
    《剑指Offer》题目:二叉树的镜像
    《剑指Offer》题目:树的子结构
    《剑指Offer》题目:合并两个排序的链表
    《剑指Offer》题目:链表中倒数第k个结点
    《剑指Offer》题目:调整数组顺序使奇数位于偶数前面
    Nginx配置http强制跳转到https
    并查集详解(转)
    AKOJ -- 1529 -- 寻找最大数
  • 原文地址:https://www.cnblogs.com/cszlg/p/2910532.html
Copyright © 2011-2022 走看看