zoukankan      html  css  js  c++  java
  • HDUOJ 1397(素数筛选法)

    Goldbach's Conjecture

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 2783    Accepted Submission(s): 1031


    Problem Description
    Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2. 
    This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

    A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.
     

    Input
    An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.
     

    Output
    Each output line should contain an integer number. No other characters should appear in the output.
     

    Sample Input
    6 10 12 0
     

    Sample Output
    1 2 1
     

    Source
     

      我开始的时候没用素数筛选法,果断TLE……

    #include <iostream>
    #define N 32769
    using namespace std;
    int main()
    {
    	int n,i,j,c,prime[N]={0};
    	//===========================
    	//筛选素数:
    	for(i=2;i<=16384;i++)
    	{
    		if(!prime[i])//prime[i]==0时意味着i前面的数都不整除i,故而i是素数
    		{
    			for(j=2;i*j<=N;j++)
    			{
    				prime[i*j]=1;
    			}
    		}
    	}
    	//==========================
    	while(scanf("%d",&n) && n!=0)
    	{
    		c=0;
    		for(i=2;i<=n/2;i++)
    		{
    			if(!prime[i] && !prime[n-i])
    			{
    				c++;
    			}
    		}
    		printf("%d\n",c);
    	}
    	return 0;
    }

    对素数筛选略作解释:
    prime[i]==0时意味着i前面的数都不整除i,故而i是素数,此时prime[i]的倍数(除自身)都是合数;当
    prime[i]==1时意味着i前面的数有能整除i的,故而i是合数,合数不执行下面的for循环是因为一个合数必能分解为若干个素数的乘积,这个合数的任一倍数(包括自身)都包含在它的任一素因子的所有倍数构成的集合中。
  • 相关阅读:
    jQuery UI DatePicker用法和中文设置
    jQuery的ajax方法
    jQuery遍历复杂的JSON数据
    JavaScript面向对象的写法
    jpa
    日志
    全局异常的处理!
    oracle表空间
    plsql的连接配置
    pLsql使用
  • 原文地址:https://www.cnblogs.com/cszlg/p/2910541.html
Copyright © 2011-2022 走看看