zoukankan      html  css  js  c++  java
  • HDUOJ 2069

    Coin Change

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 7167    Accepted Submission(s): 2385


    Problem Description
    Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

    For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

    Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
     

    Input
    The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
     

    Output
    For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
     

    Sample Input
    11 26
     

    Sample Output
    4 13
     



    #include <iostream>
    using namespace std;
    int main()
    {
    	int a,b,c,d,m,count;
    	while(scanf("%d",&m)!=EOF)
    	{
    		if(m==0) count=1;
    		else
    		{
    			count=0;
    			for(a=0;a<=m;a+=50)
    				for(b=0;a+b<=m;b+=25)
    					for(c=0;a+b+c<=m;c+=10)
    						for(d=0;a+b+c+d<=m;d+=5)
    						{
    							if(m-a-b-c-d<=100-a/50-b/25-c/10-d/5) 
    							{
    								count++;
    							}
    						}
    		}
    		printf("%d\n",count);
    	}
    	return 0;
    }


  • 相关阅读:
    专职DBA-MySQL主从延时复制
    专职DBA-MySQL主从异步复制
    专职DBA-MySQL连接启动与多实例数据库
    Java日期时间2
    Java日期时间
    763. Partition Labels
    377. Combination Sum IV
    459. Repeated Substring Pattern
    784. Letter Case Permutation
    526. Beautiful Arrangement
  • 原文地址:https://www.cnblogs.com/cszlg/p/2910543.html
Copyright © 2011-2022 走看看