zoukankan      html  css  js  c++  java
  • <poj 1046>Color Me Less

                                                                                                                                                 Color Me Less
     
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 25873   Accepted: 12417

    Description

    A color reduction is a mapping from a set of discrete colors to a smaller one. The solution to this problem requires that you perform just such a mapping in a standard twenty-four bit RGB color space. The input consists of a target set of sixteen RGB color values, and a collection of arbitrary RGB colors to be mapped to their closest color in the target set. For our purposes, an RGB color is defined as an ordered triple (R,G,B) where each value of the triple is an integer from 0 to 255. The distance between two colors is defined as the Euclidean distance between two three-dimensional points. That is, given two colors (R1,G1,B1) and (R2,G2,B2), their distance D is given by the equation

    Input

    The input is a list of RGB colors, one color per line, specified as three integers from 0 to 255 delimited by a single space. The first sixteen colors form the target set of colors to which the remaining colors will be mapped. The input is terminated by a line containing three -1 values.

    Output

    For each color to be mapped, output the color and its nearest color from the target set.

    If there are more than one color with the same smallest distance, please output the color given first in the color set.

    Sample Input

    0 0 0
    255 255 255
    0 0 1
    1 1 1
    128 0 0
    0 128 0
    128 128 0
    0 0 128
    126 168 9
    35 86 34
    133 41 193
    128 0 128
    0 128 128
    128 128 128
    255 0 0
    0 1 0
    0 0 0
    255 255 255
    253 254 255
    77 79 134
    81 218 0
    -1 -1 -1
    

    Sample Output

    (0,0,0) maps to (0,0,0)
    (255,255,255) maps to (255,255,255)
    (253,254,255) maps to (255,255,255)
    (77,79,134) maps to (128,128,128)
    (81,218,0) maps to (126,168,9)

    Source

     
    暴力解决……
    AC Code:
     
    #include <stdio.h>
    #include <math.h>
    using namespace std;
    
    struct TargetSet
    {
        int R;
        int G;
        int B;
    }c[17];
    
    int main()
    {
        int i,MinD,D,r,g,b;
        for(i=0;i<16;i++)
        {
            scanf("%d%d%d",&c[i].R,&c[i].G,&c[i].B);
        }
        while(scanf("%d%d%d",&r,&g,&b) && r!=-1)
        {
            MinD=0xfffff;
            for(i=0;i<16;i++)
            {
                D=pow((c[i].R-r)*(c[i].R-r)+(c[i].G-g)*(c[i].G-g)+(c[i].B-b)*(c[i].B-b),0.5);
                if(MinD>D)
                {
                    MinD=D;
                    c[16].B=c[i].B;
                    c[16].G=c[i].G;
                    c[16].R=c[i].R;
                    if(MinD==0) break;
                }
            }
            printf("(%d,%d,%d) maps to (%d,%d,%d)\n",r,g,b,c[16].R,c[16].G,c[16].B);
        }
        return 0;
    }
    

  • 相关阅读:
    Snapshot--使用脚本创建快照
    Mirror--日志流压缩
    Mirror--如何TSQL查看镜像状态和镜像相关存储过程
    Mirror--如何对运行中的镜像端点更换证书
    Mirror--程序访问镜像数据库的超时机制
    oozie客户端常用操作命令
    oracle数据库表空间的创建与使用
    Idea创建sbt项目
    Idea配置sbt(window环境)
    使用Idea从github上获取项目
  • 原文地址:https://www.cnblogs.com/cszlg/p/2910595.html
Copyright © 2011-2022 走看看