zoukankan      html  css  js  c++  java
  • <poj1028> Web Navigation

    Web Navigation
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 23618   Accepted: 10534

    Description

    Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this.
    The following commands need to be supported:
    BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored.
    FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored.
    VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied.
    QUIT: Quit the browser.
    Assume that the browser initially loads the web page at the URL http://www.acm.org/

    Input

    Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.

    Output

    For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

    Sample Input

    VISIT http://acm.ashland.edu/
    VISIT http://acm.baylor.edu/acmicpc/
    BACK
    BACK
    BACK
    FORWARD
    VISIT http://www.ibm.com/
    BACK
    BACK
    FORWARD
    FORWARD
    FORWARD
    QUIT

    Sample Output

    http://acm.ashland.edu/
    http://acm.baylor.edu/acmicpc/
    http://acm.ashland.edu/
    http://www.acm.org/
    Ignored
    http://acm.ashland.edu/
    http://www.ibm.com/
    http://acm.ashland.edu/
    http://www.acm.org/
    http://acm.ashland.edu/
    http://www.ibm.com/
    Ignored

    Source

     
    AC code:
    #include <iostream>
    #include <stack>
    #include <string>
    using namespace std;
    int main()
    {
        stack<string>sf,sb;//sf:stack of forward,sb:stack of backward
        string com,cp="http://www.acm.org/";//com:command,cp:current page
        while(cin>>com)
        {
            if(com[0]=='V')//faster than if(com=="VISIT")
            {
                sb.push(cp);
                cin>>cp;
                cout<<cp<<endl;
                while(!sf.empty()) sf.pop();//clear sf
            }
            else if(com[0]=='B')
            {
                if(!sb.empty())
                {
                    sf.push(cp);
                    cp=sb.top();
                    sb.pop();
                    cout<<cp<<endl;
                }
                else
                {
                    cout<<"Ignored"<<endl;
                }
            }
            else if(com[0]=='F')
            {
                if(!sf.empty())
                {
                    sb.push(cp);
                    cp=sf.top();
                    sf.pop();
                    cout<<cp<<endl;
                }
                else
                {
                    cout<<"Ignored"<<endl;
                }
            }
            else
            {
                break;
            }
        }
        return 0;
    }
    

  • 相关阅读:
    git 命令
    减少死锁的几个常用方法
    JFinal SQL in 查询排序
    并发编程中,如何减少上下文切换
    MySql批量更新
    百度编辑器上传图片自定义路径,访问路径动态加载
    百度编辑器不能插入html标签解决方法
    搭建贴吧自动签到服务
    mpv设置CPU软解
    使用Vercel+Github搭建个人博客
  • 原文地址:https://www.cnblogs.com/cszlg/p/2910597.html
Copyright © 2011-2022 走看看