zoukankan      html  css  js  c++  java
  • PAT 1002 A+B for Polynomials

    1002 A+B for Polynomials (25 分)
     

    This time, you are supposed to find A+B where A and B are two polynomials.

    Input Specification:

    Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

    N1​​ aN1​​​​ N2​​ aN2​​​​ ... NK​​ aNK​​​​

    where K is the number of nonzero terms in the polynomial, Ni​​ and aNi​​​​ (,) are the exponents and coefficients, respectively. It is given that 1,0.

    Output Specification:

    For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

    Sample Input:

    2 1 2.4 0 3.2
    2 2 1.5 1 0.5
    

    Sample Output:

    3 2 1.5 1 2.9 0 3.2

    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    
    
    int main(){
        map<int,double> mp;
        map<int,double>::iterator it;
    
        int n;
        cin >> n;
        while(n--){
            int x;double y;
            cin >> x >> y;
            mp[x]+=y;
        }
        cin >> n;
        while(n--){
            int x;double y;
            cin >> x >> y;
            mp[x]+=y;
        }
        vector<pair<int,double>> vec;
        for(it=mp.begin();it!=mp.end();it++){
    //        cout << it->first << " " << it->second << " ";
            if(it->second != 0) {
                vec.push_back(make_pair(it->first, it->second));
            }
        }
        cout << vec.size();
        for(int i=vec.size()-1;i >= 0;i--){
    //        cout << vec[i].first << " " << fixed << setprecision(1)<< vec[i].second;
            printf(" %d %.1f",vec[i].first,vec[i].second);
    
        }
    
        return 0;
    }

    ——map  make_pair vector 之间的骚操作。。

     
  • 相关阅读:
    一个由“ YYYYMMdd ”引发的惨案 !元旦来临前的警惕
    elasticJob 自定义任务参数
    java 生成GUID
    java ArrayList和LinkedList的区别
    Linux下配置python Jupyter远程访问
    《Go并发编程实战》系列二:多线程编程
    《Go并发编程实战》系列一:多进程编程
    《Go并发编程实战》学习基础
    归并排序递归方式和非递归(Java)
    滕讯一面总结
  • 原文地址:https://www.cnblogs.com/cunyusup/p/10663925.html
Copyright © 2011-2022 走看看