zoukankan      html  css  js  c++  java
  • PAT 1019 General Palindromic Number

    1019 General Palindromic Number (20 分)
     

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b2, where it is written in standard notation with k+1 digits ai​​ as (. Here, as usual, 0 for all i and ak​​ is non-zero. Then N is palindromic if and only if ai​​=aki​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

    Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

    Input Specification:

    Each input file contains one test case. Each case consists of two positive numbers N and b, where 0 is the decimal number and 2 is the base. The numbers are separated by a space.

    Output Specification:

    For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "ak​​ ak1​​ ... a0​​". Notice that there must be no extra space at the end of output.

    Sample Input 1:

    27 2
    

    Sample Output 1:

    Yes
    1 1 0 1 1
    

    Sample Input 2:

    121 5
    

    Sample Output 2:

    No
    4 4 1
    

    鸣谢网友“CCPC拿不到牌不改名”修正数据!

    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    #define maxnum 100005
    
    
    
    
    
    
    int main(){
        int a,b;
        scanf("%d%d",&a,&b);
        vector<int> vec;
        while(a){
            vec.push_back(a%b);
            a /= b;
        }
    //    for(auto num:vec)cout << num << " ";
    
        int flag = 1;
        for(int i=0;i < vec.size()/2+1;i++){
            if(vec[i] != vec[vec.size()-i-1])flag = 0;
        }
        if(flag)cout << "Yes" << endl;
        else cout << "No" << endl;
    
        for(int i=vec.size()-1;i >= 0;i--){
            cout << vec[i];
            if(i!=0)cout << " ";
        }
        return 0;
    }

  • 相关阅读:
    Org4的約會的Form_Load
    MSCRM 4 Remove 'Add Existing xxxxx to this record' button
    出售剩余时间
    MSCRM中disabled和Disabled屬性的區別
    一些常用的sql
    約會的客戶變更時取其它表的資料
    MSCRM儲存disabled欄位的值
    CRM显示产品图片
    顯示Object的所有屬性及處理ContactId只列出ParentCustomer的資料的javascript
    浅谈递归过程以及递归的优化
  • 原文地址:https://www.cnblogs.com/cunyusup/p/10696416.html
Copyright © 2011-2022 走看看