zoukankan      html  css  js  c++  java
  • PAT 1116 Come on! Let's C

    1116 Come on! Let's C (20 分)
     

    "Let's C" is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

    • 0、 The Champion will receive a "Mystery Award" (such as a BIG collection of students' research papers...).
    • 1、 Those who ranked as a prime number will receive the best award -- the Minions (小黄人)!
    • 2、 Everyone else will receive chocolates.

    Given the final ranklist and a sequence of contestant ID's, you are supposed to tell the corresponding awards.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant's ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID's.

    Output Specification:

    For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding?instead. If the ID has been checked before, print ID: Checked.

    Sample Input:

    6
    1111
    6666
    8888
    1234
    5555
    0001
    6
    8888
    0001
    1111
    2222
    8888
    2222
    

    Sample Output:

    8888: Minion
    0001: Chocolate
    1111: Mystery Award
    2222: Are you kidding?
    8888: Checked
    2222: Are you kidding?
    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    
    bool is_prime(int x){
        for(int i=2;i <= sqrt(x);i++){
            if(x%i == 0) return false;
        }
        return true;
    }
    
    
    
    
    
    int main(){
    
        int n;
        cin >> n;
        map<string,string> mp;
    
    
        for(int i=1;i <= n;i++){
            string s;
            cin >> s;
            if(i==1){mp[s] = "Mystery Award";}
            else if(is_prime(i)){mp[s] = "Minion";}
            else if(!is_prime(i)){mp[s] = "Chocolate";}
        }
    
        int q;
        cin >> q;
        while(q--){
            string s;
            cin >> s;
            cout << s << ": ";
            if(mp[s] == "")cout << "Are you kidding?"<< endl;
            else if(mp[s] == "Checked") cout << "Checked" << endl;
            else if(mp[s] == "Minion"){
                cout << "Minion" << endl;
                mp[s] = "Checked";
            }
            else if(mp[s] == "Mystery Award"){
                cout << "Mystery Award" << endl;
                mp[s] = "Checked";
            }
            else if(mp[s] == "Chocolate"){
                cout << "Chocolate" << endl;
                mp[s] = "Checked";
            }
    
        }
    
    
    
        return 0;
    }

    白给题,map的运用。

     
  • 相关阅读:
    基于.NET CORE微服务框架 -谈谈Cache中间件和缓存降级
    基于.NET CORE微服务框架 -谈谈surging的服务容错降级
    基于.NET CORE微服务框架 -surging的介绍和简单示例 (开源)
    Git学习记录-基本命令篇
    一个实例搞懂二重指针
    不能将X*类型的值分配到X*类型的实体问题的解决方法
    如何将idea工程打包成jar文件
    windows10环境下安装深度学习环境anaconda+pytorch+CUDA+cuDDN
    指针、地址和引用学习笔记
    几行代码实现cookie的盗取
  • 原文地址:https://www.cnblogs.com/cunyusup/p/10791578.html
Copyright © 2011-2022 走看看