zoukankan      html  css  js  c++  java
  • PAT 1022 Digital Library

    1022 Digital Library (30 分)
     

    A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

    • Line #1: the 7-digit ID number;
    • Line #2: the book title -- a string of no more than 80 characters;
    • Line #3: the author -- a string of no more than 80 characters;
    • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
    • Line #5: the publisher -- a string of no more than 80 characters;
    • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

    It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

    After the book information, there is a line containing a positive integer M (≤) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

    • 1: a book title
    • 2: name of an author
    • 3: a key word
    • 4: name of a publisher
    • 5: a 4-digit number representing the year

    Output Specification:

    For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

    Sample Input:

    3
    1111111
    The Testing Book
    Yue Chen
    test code debug sort keywords
    ZUCS Print
    2011
    3333333
    Another Testing Book
    Yue Chen
    test code sort keywords
    ZUCS Print2
    2012
    2222222
    The Testing Book
    CYLL
    keywords debug book
    ZUCS Print2
    2011
    6
    1: The Testing Book
    2: Yue Chen
    3: keywords
    4: ZUCS Print
    5: 2011
    3: blablabla
    

    Sample Output:

    1: The Testing Book
    1111111
    2222222
    2: Yue Chen
    1111111
    3333333
    3: keywords
    1111111
    2222222
    3333333
    4: ZUCS Print
    1111111
    5: 2011
    1111111
    2222222
    3: blablabla
    Not Found
    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    #define MAXN 500
    
    struct node{
        string bookid;
        string name;
        string author;
        vector<string> keyword;
        string publisher;
        string year;
    };
    
    bool comp(string s1,string s2){
        return s1 < s2;
    }
    
    
    
    
    int main(){
    //    freopen("datain","r",stdin);
    //    freopen("dataout","w",stdout);
        int n;
        cin >> n; getchar();
        node nod[n];
        for(int k=0;k < n;k++){
            string s1;getline(cin,s1);nod[k].bookid = s1;
            string s2;getline(cin,s2);nod[k].name = s2;
            string s3;getline(cin,s3);nod[k].author = s3;
            string s4;getline(cin,s4);
            int pos=0;
            for(int i=0;i<s4.size();i++){
                if(s4[i]==' ') {
                    nod[k].keyword.push_back(s4.substr(pos,i-pos));
                    pos = i+1;
                }
            }
            nod[k].keyword.push_back(s4.substr(pos,s4.size()-pos));
            string s5;getline(cin,s5);nod[k].publisher = s5;
            string s6;getline(cin,s6);nod[k].year = s6;
    //        for(auto x:nod[k].keyword){
    //            cout << x << " ";
    //        }
        }
    
    
        int Q; cin >> Q;getchar();
        for(int k=0;k < Q;k++){
            string s; getline(cin,s); cout << s << endl;
            string t = s.substr(3,s.size()-3);
            if(s[0]=='1'){
                int flag=1;
                vector<string> temp;
                for(int i=0;i < n;i++){
                    if(nod[i].name == t){temp.push_back(nod[i].bookid);flag=0;}
                }
                sort(temp.begin(),temp.end(),comp);
                for(auto x:temp) cout << x << endl;
                if(flag) cout << "Not Found" << endl;
            }
            else if(s[0] == '2'){
                int flag=1;
                vector<string> temp;
                for(int i=0;i < n;i++){
                    if(nod[i].author == t){temp.push_back(nod[i].bookid);flag=0;}
                }
                sort(temp.begin(),temp.end(),comp);
                for(auto x:temp) cout << x << endl;
                if(flag) cout << "Not Found" << endl;
            }
            else if(s[0] == '3'){
                int flag=1;
                vector<string> temp;
                for(int i=0;i < n;i++){
                    for(int j=0;j < nod[i].keyword.size();j++){
                        if(nod[i].keyword[j] == t){
                            temp.push_back(nod[i].bookid); 
                            flag=0;
                            break;
                        }
                    }
                }
                sort(temp.begin(),temp.end(),comp);
                for(auto x:temp) cout << x << endl;
                if(flag) cout << "Not Found" << endl;
            }
            else if(s[0] == '4'){
                int flag=1;
                vector<string> temp;
                for(int i=0;i < n;i++){
                    if(nod[i].publisher == t){temp.push_back(nod[i].bookid);flag=0;}
                }
                sort(temp.begin(),temp.end(),comp);
                for(auto x:temp) cout << x << endl;
                if(flag) cout << "Not Found" << endl;
            }
            else if(s[0] == '5'){
                int flag=1;
                vector<string> temp;
                for(int i=0;i < n;i++){
                    if(nod[i].year == t){temp.push_back(nod[i].bookid);flag=0;}
                }
                sort(temp.begin(),temp.end(),comp);
                for(auto x:temp) cout << x << endl;
                if(flag) cout << "Not Found" << endl;
            }
        }
    
    
        return 0;
    }

    码农题,一开始忘记把文件打开关闭注释了,然后全错了,体会到一些oi小朋友的感受了

     
  • 相关阅读:
    Andrew Ng机器学习算法入门((七):特征选择和多项式回归
    Andrew Ng机器学习算法入门((六):多变量线性回归方程求解
    Andrew Ng机器学习算法入门((五):矩阵和向量
    Linux常用命令集锦
    Andrew Ng机器学习算法入门(四):阶梯下降算法
    AZscaaner源码解读之数据库连接(一)
    Andrew Ng机器学习算法入门(三):线性回归算法
    Andrew Ng机器学习算法入门(二):机器学习分类
    MapServer
    fetch.js
  • 原文地址:https://www.cnblogs.com/cunyusup/p/10815837.html
Copyright © 2011-2022 走看看