zoukankan      html  css  js  c++  java
  • PAT 1025 PAT Ranking

    1025 PAT Ranking (25 分)
     

    Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive number N (≤), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

    registration_number final_rank location_number local_rank
    

    The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

    Sample Input:

    2
    5
    1234567890001 95
    1234567890005 100
    1234567890003 95
    1234567890002 77
    1234567890004 85
    4
    1234567890013 65
    1234567890011 25
    1234567890014 100
    1234567890012 85
    

    Sample Output:

    9
    1234567890005 1 1 1
    1234567890014 1 2 1
    1234567890001 3 1 2
    1234567890003 3 1 2
    1234567890004 5 1 4
    1234567890012 5 2 2
    1234567890002 7 1 5
    1234567890013 8 2 3
    1234567890011 9 2 4
    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    #define MAXN 500
    
    struct node{
        string userid;
        int point;
        int globalranknumber;
        int blocknumber;
        int localranknumber;
    };
    
    
    node nod[30005];
    
    bool comp(node a,node b){
        return a.point > b.point;
    }
    
    bool comp2(node a,node b){
        if(a.point == b.point)
            return a.userid < b.userid;
        return a.point > b.point;
    }
    
    int main(){
        int t;
        cin >> t;
        int pos = 0;
        int cnt = 1;
        int sum = 0;
        while(t--){
            int n; cin >> n;
            sum += n;
            for(int i=pos;i < n+pos;i++){
                string xxx; cin >> xxx;
                int scor; cin >> scor;
                nod[i].userid = xxx;
                nod[i].point = scor;
                nod[i].blocknumber = cnt;
            }
            sort(nod+pos,nod+pos+n,comp);
    //        for(int i=pos;i < n+pos;i++){
    //            cout << nod[i].point << " ";
    //        }
            nod[pos].localranknumber = 1;
            for(int i=pos+1;i < n+pos;i++){
                if(nod[i].point != nod[i-1].point){
                    nod[i].localranknumber = i-pos+1;
                }
                else{
                    nod[i].localranknumber = nod[i-1].localranknumber;
                }
            }
            pos += n;
            cnt++;
    //        for(int i=pos;i < n+pos;i++){
    //            cout << nod[i].point << " " << nod[i].localranknumber << endl;
    //        }
        }
    
    
        sort(nod,nod+sum,comp2);
    
        nod[0].globalranknumber = 1;
        for(int i=1;i < sum;i++){
            if(nod[i].point != nod[i-1].point){
                nod[i].globalranknumber = i+1;
            }
            else{
                nod[i].globalranknumber = nod[i-1].globalranknumber;
            }
    
        }
    
    
        cout << sum << endl;
        for(int i=0;i < sum;i++){
            cout << nod[i].userid << " " << nod[i].globalranknumber << " " << nod[i].blocknumber << " " << nod[i].localranknumber << endl;
        }
    
    
    
    
        return 0;
    }
    
    
    //int main(){
    //    string s2 = "1234567890003";
    //    string s1 = "1234567890001";
    //    cout << (s1<s2);
    //    return 0;
    //}

    一开始写成pos = n;

    cao

     
  • 相关阅读:
    dapperHelper
    .NET Core Session的使用方法
    Wpf 关闭当前窗体 打开新窗体
    C#中Split分隔字符串的应用(C#、split、分隔、字符串)
    wpf日期控件
    SQLite数据库数据类型详解
    Asp.Net Core 2.2
    手写图片懒加载
    css动画常用属性总结
    css购物车(抛物线)运动
  • 原文地址:https://www.cnblogs.com/cunyusup/p/10822046.html
Copyright © 2011-2022 走看看