zoukankan      html  css  js  c++  java
  • PAT 1032 Sharing

    1032 Sharing (25 分)
     

    To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

    fig.jpg

    Figure 1

    You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −.

    Then N lines follow, each describes a node in the format:

    Address Data Next
    

    whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

    Output Specification:

    For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

    Sample Input 1:

    11111 22222 9
    67890 i 00002
    00010 a 12345
    00003 g -1
    12345 D 67890
    00002 n 00003
    22222 B 23456
    11111 L 00001
    23456 e 67890
    00001 o 00010
    

    Sample Output 1:

    67890
    

    Sample Input 2:

    00001 00002 4
    00001 a 10001
    10001 s -1
    00002 a 10002
    10002 t -1
    

    Sample Output 2:

    -1
    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    #define MAXN 100005
    
    int vis[MAXN] = {0};
    
    
    int main(){
        int a,b,n;
        cin >> a >> b >> n;
        map<int,int> mp;
        for(int i=0;i < n;i++){
            int x,y;
            char t;
            scanf("%d %c %d",&x,&t,&y);
    //cin >> x >> t >> y;
            mp[x] = y;
        }
    
        while(a!=-1){
            vis[a] = 1;
            a = mp[a];
        }
    
        while(1){
            if(b==-1){printf("-1");break;}
            if(vis[b]){printf("%05d",b);break;}
            b = mp[b];
        }
    //    int temp = b;
    //    while(1){
    //        if(a==-1){printf("-1");break;}
    //        b = temp;
    //        while(1){
    //            if(b==-1){ break;}
    //            if(a == b){printf("%05d",a);return 0;}
    //            b = mp[b];
    //        }
    //        a = mp[a];
    //    }
    
    
        return 0;
    }

    一开始写了O(N^2)的暴力,后来改了遍历第一条链表,将访问过的结点的flag都标记为true,当遍历第二条结点的时候,如果遇到了true的结点就输出并结束程序,没有遇到就输出-1

    然后输入又被卡,cin过不了(以后发现输入大于10^5就用scanf吧)char --> %c  输入要空格和printf一样,真是麻烦死

     
  • 相关阅读:
    Codeforces Round #604(Div. 2,
    简单的三层框架以及使用dbutils进行数据库操作(入门)
    DBUtil数据库工具封装
    GUI 中监听 文本框实时改变的实例
    java基础教程GUI
    Dao层通用化,Spring3.0+Hibernate3.3.2通用Dao层整合
    计算器代码
    记事本应用程序java源代码
    GUI
    dbutils开源项目用法
  • 原文地址:https://www.cnblogs.com/cunyusup/p/10823600.html
Copyright © 2011-2022 走看看