zoukankan      html  css  js  c++  java
  • UVa 674 Coin Change 背包dp



      Coin Change 

    Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.


    For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.


    Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

    Input 

    The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

    Output 

    For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

    Sample Input 

    11
    26
    

    Sample Output 

    4
    13
    


    ------------------



    ----------------

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    
    using namespace std;
    
    const int OO=1e9;
    
    int f[11111];
    int n;
    int a[5]={1,5,10,25,50};
    
    int main()
    {
        while (~scanf("%d",&n))
        {
            memset(f,0,sizeof(f));
            f[0]=1;
            for (int i=0;i<5;i++)
            {
                for (int j=0;j<=n-a[i];j++)
                {
                    if (f[j]) f[j+a[i]]+=f[j];
                }
            }
            printf("%d\n",f[n]);
        }
        return 0;
    }
    





      Coin Change 

    Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.


    For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.


    Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

    Input 

    The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

    Output 

    For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

    Sample Input 

    11
    26
    

    Sample Output 

    4
    13
    


  • 相关阅读:
    0719PHP基础:PDO
    0717PHP基础:面向对象
    0716PHP基础:面向对象
    0715JS基础:ajax
    0715PHP练习:文件操作
    0715PHP基础:文件操作
    0629正则表达式:基础
    0628正则表达式:练习
    zTree简单使用和代码结构
    servlet
  • 原文地址:https://www.cnblogs.com/cyendra/p/3038369.html
Copyright © 2011-2022 走看看