zoukankan      html  css  js  c++  java
  • 线段树 1698 Just a Hook 区间set更新

    Just a Hook

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 11297    Accepted Submission(s): 5591


    Problem Description
    In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



    Now Pudge wants to do some operations on the hook.

    Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
    The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

    For each cupreous stick, the value is 1.
    For each silver stick, the value is 2.
    For each golden stick, the value is 3.

    Pudge wants to know the total value of the hook after performing the operations.
    You may consider the original hook is made up of cupreous sticks.
     

    Input
    The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
    For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
    Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
     

    Output
    For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
     

    Sample Input
    1 10 2 1 5 2 5 9 3
     

    Sample Output
    Case 1: The total value of the hook is 24.
     



    #include<iostream>
    #include<cstdio>
    #include<cmath>
    #include<cstring>
    #include<algorithm>
    #define N 222222
    
    using namespace std;
    
    int num[N];
    
    struct Tree
    {
        int l;
        int r;
        int sum;
        int col;
    } tree[N*4];
    
    void push_up(int rt)
    {
        tree[rt].sum=tree[rt<<1].sum+tree[rt<<1|1].sum;
    }
    
    void push_down(int rt,int m)
    {
        if (tree[rt].col>0)
        {
            tree[rt<<1].col=tree[rt<<1|1].col=tree[rt].col;
            tree[rt<<1].sum=(m-(m/2))*tree[rt].col;
            tree[rt<<1|1].sum=(m/2)*tree[rt].col;
            tree[rt].col=0;
        }
    }
    
    void build(int root,int l,int r)
    {
        tree[root].l=l;
        tree[root].r=r;
        tree[root].sum=1;
        tree[root].col=0;
        if(tree[root].l==tree[root].r)
        {
            return;
        }
        int mid=(l+r)/2;
        build(root<<1,l,mid);
        build(root<<1|1,mid+1,r);
        push_up(root);
    }
    
    void update(int root,int L,int R,int val)
    {
        if(L<=tree[root].l&&R>=tree[root].r)
        {
            tree[root].col=val;
            tree[root].sum=val*(tree[root].r-tree[root].l+1);
            return;
        }
        push_down(root,tree[root].r-tree[root].l+1);
        int mid=(tree[root].l+tree[root].r)/2;
        if (L<=mid)
            update(root<<1,L,R,val);
        if (R>mid)
            update(root<<1|1,L,R,val);
        push_up(root);
    }
    
    int main()
    {
        int n,q,T;
        scanf("%d",&T);
        for (int lp=1;lp<=T;lp++)
        {
            scanf("%d",&n);
            build(1,1,n);
            scanf("%d",&q);
            while (q--)
            {
                int x,y,z;
                scanf("%d%d%d",&x,&y,&z);
                update(1,x,y,z);
            }
            int ans=tree[1].sum;
            printf("Case %d: The total value of the hook is %d.\n",lp,ans);
        }
        return 0;
    }
    



  • 相关阅读:
    每日总结2.26
    《梦断代码》阅读笔记三
    每日总结2.25
    每日总结2.24
    每日总结2.23
    每日总结2.22
    每日总结2.19
    《梦断代码》阅读笔记二
    Java-11 形参和实参
    Java-10 final用法
  • 原文地址:https://www.cnblogs.com/cyendra/p/3038420.html
Copyright © 2011-2022 走看看