zoukankan      html  css  js  c++  java
  • NEFU 722 Anagram 全排列 STL

    Anagram

    Time Limit 4000ms

    Memory Limit 65536K

    description

    You are to write a program that has to generate all possible words from a given set of letters. Example: Given the word "abc", your program should - by exploring all different combination of the three letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba". In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order.
    An upper case letter goes before the corresponding lower case letter. So the right order of letters is 'A'<'a'<'B'<'b'<...<'Z'<'z'. 
    
    
    							

    input

    The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters are to be considered different. The length of each word is less than 13. 
    
    
    							

    output

    For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order. An upper case letter goes before the corresponding lower case letter. 
    
    
    							

    sample_input

    3
    aAb
    abc
    acba
    
    
    							

    sample_output

    Aab
    Aba
    aAb
    abA
    bAa
    baA
    abc
    acb
    bac
    bca
    cab
    cba
    aabc
    aacb
    abac
    abca
    acab
    acba
    baac
    baca
    bcaa
    caab
    caba
    cbaa
    

    --------------

    next_permutation(a,a+n)

    --------------

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    
    using namespace std;
    
    char s[111];
    int a[111];
    int len;
    
    int main()
    {
        int T;
        scanf("%d",&T);
        while (T--)
        {
            memset(a,0,sizeof(a));
            memset(s,0,sizeof(s));
            scanf("%s",s);
            len=strlen(s);
            for (int i=0;i<len;i++)
            {
                if (s[i]>='a'&&s[i]<='z')
                {
                    a[i]=(s[i]-'a')*2+1;
                }
                if (s[i]>='A'&&s[i]<='Z')
                {
                    a[i]=(s[i]-'A')*2;
                }
            }
            sort(a,a+len);
            //for (int i=0;i<len;i++) cerr<<a[i]<<" ";
            //cerr<<endl;
            do
            {
                for (int i=0;i<len;i++)
                {
                    if (a[i]&1)
                    {
                        printf("%c",(a[i]-1)/2+'a');
                    }
                    else
                    {
                        printf("%c",a[i]/2+'A');
                    }
                }
                puts("");
            }while (next_permutation(a,a+len));
        }
        return 0;
    }
    




  • 相关阅读:
    golang基础之第一个go程序
    golang基础之工程结构
    golang基础之初识
    Prometheus神器之监控K8s集群
    Kubernetes使用GlusterFS实现数据持久化
    Go使用Makefile构建
    快排的2种分区图解
    密钥交换之DH算法
    go mod使用
    socket常见选项之SO_REUSEADDR,SO_REUSEPORT
  • 原文地址:https://www.cnblogs.com/cyendra/p/3226306.html
Copyright © 2011-2022 走看看