zoukankan      html  css  js  c++  java
  • NEFU 722 Anagram 全排列 STL

    Anagram

    Time Limit 4000ms

    Memory Limit 65536K

    description

    You are to write a program that has to generate all possible words from a given set of letters. Example: Given the word "abc", your program should - by exploring all different combination of the three letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba". In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order.
    An upper case letter goes before the corresponding lower case letter. So the right order of letters is 'A'<'a'<'B'<'b'<...<'Z'<'z'. 
    
    
    							

    input

    The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters are to be considered different. The length of each word is less than 13. 
    
    
    							

    output

    For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order. An upper case letter goes before the corresponding lower case letter. 
    
    
    							

    sample_input

    3
    aAb
    abc
    acba
    
    
    							

    sample_output

    Aab
    Aba
    aAb
    abA
    bAa
    baA
    abc
    acb
    bac
    bca
    cab
    cba
    aabc
    aacb
    abac
    abca
    acab
    acba
    baac
    baca
    bcaa
    caab
    caba
    cbaa
    

    --------------

    next_permutation(a,a+n)

    --------------

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    
    using namespace std;
    
    char s[111];
    int a[111];
    int len;
    
    int main()
    {
        int T;
        scanf("%d",&T);
        while (T--)
        {
            memset(a,0,sizeof(a));
            memset(s,0,sizeof(s));
            scanf("%s",s);
            len=strlen(s);
            for (int i=0;i<len;i++)
            {
                if (s[i]>='a'&&s[i]<='z')
                {
                    a[i]=(s[i]-'a')*2+1;
                }
                if (s[i]>='A'&&s[i]<='Z')
                {
                    a[i]=(s[i]-'A')*2;
                }
            }
            sort(a,a+len);
            //for (int i=0;i<len;i++) cerr<<a[i]<<" ";
            //cerr<<endl;
            do
            {
                for (int i=0;i<len;i++)
                {
                    if (a[i]&1)
                    {
                        printf("%c",(a[i]-1)/2+'a');
                    }
                    else
                    {
                        printf("%c",a[i]/2+'A');
                    }
                }
                puts("");
            }while (next_permutation(a,a+len));
        }
        return 0;
    }
    




  • 相关阅读:
    (4.21)SQL Server数据库启动过程(用户数据库加载过程的疑难杂症)
    (4.20)SQL Server数据库启动过程,以及启动不起来的各种问题的分析及解决技巧
    sql server常用性能计数器
    阿里云教程
    (2.7)Mysql之SQL基础——表的操作与查看
    配置公网的域名绑定IP
    VisualSVN Server 从此告别SVN记事本配置
    Bluestacks 安卓模拟器利器
    f.lux亮度自动改变
    开发以及需求分析误区陷阱汇总
  • 原文地址:https://www.cnblogs.com/cyendra/p/3226306.html
Copyright © 2011-2022 走看看