zoukankan      html  css  js  c++  java
  • 10131 Is Bigger Smarter? 水dp

    Question 1: Is Bigger Smarter?

    The Problem

    Some people think that the bigger an elephant is, the smarter it is. To disprove this, you want to take the data on a collection of elephants and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the IQ's are decreasing.

    The input will consist of data for a bunch of elephants, one elephant per line, terminated by the end-of-file. The data for a particular elephant will consist of a pair of integers: the first representing its size in kilograms and the second representing its IQ in hundredths of IQ points. Both integers are between 1 and 10000. The data will contain information for at most 1000 elephants. Two elephants may have the same weight, the same IQ, or even the same weight and IQ.

    Say that the numbers on the i-th data line are W[i] and S[i]. Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing an elephant). If these n integers are a[1]a[2],..., a[n] then it must be the case that

       W[a[1]] < W[a[2]] < ... < W[a[n]]
    
    and
       S[a[1]] > S[a[2]] > ... > S[a[n]]
    
    In order for the answer to be correct, n should be as large as possible. All inequalities are strict: weights must be strictly increasing, and IQs must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

    Sample Input

    6008 1300
    6000 2100
    500 2000
    1000 4000
    1100 3000
    6000 2000
    8000 1400
    6000 1200
    2000 1900
    

    Sample Output

    4
    4
    5
    9
    7
    ---------



    -----------

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    
    using namespace std;
    
    struct EL{
        int x;
        int y;
        int id;
    }a[11111];
    
    bool cmp(EL a,EL b)
    {
        if (a.x==b.x) return a.id<b.id;
        return a.x<b.x;
    }
    
    int n;
    int f[11111]={0};
    int p[11111]={0};
    int ans[11111]={0};
    int cnt;
    
    int main()
    {
        n=1;
        while (~scanf("%d%d",&a[n].x,&a[n].y)){a[n].id=n;n++;}
        n--;
        sort(a+1,a+n+1,cmp);
        int mx=0;
        int ww=0;
        //for (int i=1;i<=n;i++){cerr<<a[i].x<<" "<<a[i].y<<" "<<a[i].id<<endl;}
        for (int i=1;i<=n;i++)
        {
            f[i]=1;
            p[i]=0;
            for (int k=1;k<i;k++)
            {
                if (a[i].y<a[k].y&&a[i].x>a[k].x&&f[k]+1>f[i])
                {
                    f[i]=f[k]+1;
                    p[i]=k;
                }
            }
            if (f[i]>mx)
            {
                mx=f[i];
                ww=i;
            }
        }
        //for (int i=1;i<=n;i++) cerr<<f[i]<<" ";cerr<<endl;
        printf("%d\n",mx);
        cnt=0;
        while (ww!=0)
        {
            ans[cnt++]=a[ww].id;
            ww=p[ww];
        }
        for (int i=cnt-1;i>=0;i--)
        {
            printf("%d\n",ans[i]);
        }
        return 0;
    }
    



  • 相关阅读:
    [20190905] 考试卷子分析
    tmp
    分层图——孤岛营救
    [BNDSOJ] #1106代码
    [BNDSOJ] 小P的数列代码
    补充[BNDSOJ]小p的数列
    针对【H-2017年信息基础班(周一班)】某些同学恶意使用lyl洛谷的谴责
    #1086. 受欢迎的牛
    [sol]250OJ 1~10
    编译原理之词法分析(大三生活第21天,度过了一段萎靡的时光)
  • 原文地址:https://www.cnblogs.com/cyendra/p/3226347.html
Copyright © 2011-2022 走看看