zoukankan      html  css  js  c++  java
  • NEFU 697 Similar Word KMP

    Similar Word

    Time Limit 1000ms

    Memory Limit 65536K

    description

      It was a crummy day for Lur. He failed to pass to the CET-6 (College English Test Band-6). Looking back on how it was in last year gone by, he gradually noticed he had fled too many English Lessons. But he determines to memorize words on his bed ,not in the classroom. You know, it is not that easy to pass the test mainly because the large amount of born words. 
         Lur is intelligent on games , never English. He cann't learn the similar words by heart. He 
    always choose to select a word to learn from the similar words . For him, two words are similar if and only if one word can equal to the other by multiple cyclic shift(at least 1). For example, "car" and "arc" are similar words, while "car" and "rca" are also similar words . To save more time to play games, 
      Lur want to know wether two words are similar words faster, he asks you to write a program to tell him ,can you help him ? 
    							

    input

      There are multiple test cases. Each case contains two lines. Each line contains a word, 
    W. You can assume that length(W)<=10^5 . Ended by EOF.
    							

    output

      Output “yes” in a single line if two words are similar,otherwise you should output  “no” in a single line.
    							

    sample_input

    car
    arc
    car
    cra
    car
    car
    							

    sample_output

    yes
    no
    no
    							

    -------------

    KMP

    但是!!直接暴力也能过!!!魂淡!!!!

    ------------

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    
    using namespace std;
    
    char T[1111111];
    char P[1111111];
    int  f[1111111];
    
    
    bool find()
    {
        int n=strlen(T),m=strlen(P);
        f[0]=0;
        f[1]=0;
        for (int i=1; i<m; i++)
        {
            int j=f[i];
            while (j && P[i]!=P[j]) j=f[j];
            f[i+1]=(P[i]==P[j])?(j+1):(0);
        }
    
        int j=0;
        for (int i=0; i<n; i++)
        {
            while (j && P[j]!=T[i]) j=f[j];
            if (P[j]==T[i]) j++;
            if (j==m) return true;
        }
        return false;
    }
    
    int main()
    {
        while (~scanf("%s%s",T,P))
        {
            memset(f,0,sizeof(f));
            int lenT=strlen(T);
            int lenP=strlen(P);
            if (lenT!=lenP)
            {
                printf("no\n");
            }
            else if (strcmp(P,T)==0)
            {
                printf("no\n");
            }
            else
            {
                for (int i=lenT; i<lenT*2; i++)
                {
                    T[i]=T[i-lenT];
                }
                T[lenT*2]='\0';
                if (find())
                {
                    printf("yes\n");
                }
                else
                {
                    printf("no\n");
                }
            }
    
        }
        return 0;
    }
    


  • 相关阅读:
    使用 jsPlumb 绘制拓扑图 —— 异步加载与绘制的实现
    改善记忆力的二十种记忆方法,随便你挑!
    怎样完成一次比较漂亮的晋升面试演讲
    产品运维的思考与总结
    Jtester+unitils+testng:DAO单元测试文件模板自动生成
    生活、工作和理想
    推荐《需求:缔造伟大商业传奇的根本力量》
    星光之旅
    谈读书
    生命之反思
  • 原文地址:https://www.cnblogs.com/cyendra/p/3226386.html
Copyright © 2011-2022 走看看