zoukankan      html  css  js  c++  java
  • 1084. Broken Keyboard (20)【字符串操作】——PAT (Advanced Level) Practise

    题目信息

    1084. Broken Keyboard (20)

    时间限制200 ms
    内存限制65536 kB
    代码长度限制16000 B
    On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

    Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

    Input Specification:

    Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or “_” (representing the space). It is guaranteed that both strings are non-empty.

    Output Specification:

    For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

    Sample Input:
    7_This_is_a_test
    _hs_s_a_es
    Sample Output:
    7TI

    解题思路

    水题

    AC代码

    #include <cstdio>
    #include <cstring>
    #include <set>
    #include <cctype>
    using namespace std;
    int main()
    {
        char s[100], a[100], r[100];
        set<char> st;
        scanf("%s%s", s, a);
        int len = strlen(s), cnt = 0;
        for (int i = 0; i < len; ++i){
            if (NULL == strchr(a, s[i])){
                if (st.insert(toupper(s[i])).second){
                    r[cnt++] = toupper(s[i]);
                }
            }
        }
        for (int i = 0; i < cnt; ++i){
            putchar(r[i]);
        }
        return 0;
    }
  • 相关阅读:
    选择排序
    unity面试准备
    标识位
    table.insert(tableName, v)
    使用bmfont制作字体
    长按tools Icon 弹出Tips音效
    钓鱼功能
    jQuery鼠标移到小图显示大图效果
    ThinkPHP3.2.3中如何显示二级栏目
    ThinkPHP3.2.2自定义success及error跳转页面
  • 原文地址:https://www.cnblogs.com/cynchanpin/p/7250367.html
Copyright © 2011-2022 走看看