zoukankan      html  css  js  c++  java
  • msdp rpf 规则1


    配置命令
    R1===================================
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    clock timezone EST -5
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    ip source-route
    !
    !
    !         
    !
    ip cef
    no ip domain lookup
    ip multicast-routing 
    no ipv6 traffic interface-statistics
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    redundancy

    !
    !
    !
    !         
    !
    !
    !
    !
    interface Loopback0
     ip address 1.1.1.1 255.255.255.255
     ip pim sparse-mode
     ip igmp join-group 239.1.1.1
    !
    interface Ethernet0/0
     no ip address
    !
    interface Ethernet0/0.12
     encapsulation dot1Q 12
     ip address 12.1.1.1 255.255.255.0
     ip pim bsr-border
     ip pim sparse-mode
    !
    interface Ethernet0/1
     no ip address
     shutdown
    !
    interface Ethernet0/2
     no ip address
     shutdown
    !
    interface Ethernet0/3
     no ip address
     shutdown
    !
    interface Serial1/0
     no ip address
     shutdown
     no fair-queue
     serial restart-delay 0
    !
    interface Serial1/1
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/2
     no ip address
     shutdown
     serial restart-delay 0
    !         
    interface Serial1/3
     no ip address
     shutdown
     serial restart-delay 0
    !
    router bgp 100
     no synchronization
     bgp log-neighbor-changes
     network 1.1.1.1 mask 255.255.255.255
     neighbor 12.1.1.2 remote-as 200
     no auto-summary
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    ip pim bsr-candidate Loopback0 0
    ip pim rp-candidate Loopback0
    ip msdp peer 2.2.2.2 connect-source Loopback0
    ip msdp cache-sa-state
    !
    !         
    !
    !
    !
    !
    !
    control-plane
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
    line aux 0
    line vty 0 4
     login
    !
    exception data-corruption buffer truncate
    end
    R2===================================
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R2
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    clock timezone EST -5
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    ip source-route
    !
    !
    !         
    !
    ip cef
    no ip domain lookup
    ip multicast-routing 
    no ipv6 traffic interface-statistics
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    redundancy

    !
    !
    !
    !         
    !
    !
    !
    !
    interface Loopback0
     ip address 2.2.2.2 255.255.255.255
     ip pim sparse-mode
    !
    interface Ethernet0/0
     no ip address
    !
    interface Ethernet0/0.12
     encapsulation dot1Q 12
     ip address 12.1.1.2 255.255.255.0
     ip pim bsr-border
     ip pim sparse-mode
    !
    interface Ethernet0/0.23
     encapsulation dot1Q 23
     ip address 23.1.1.2 255.255.255.0
     ip pim bsr-border
     ip pim sparse-mode
    !         
    interface Ethernet0/1
     no ip address
     shutdown
    !
    interface Ethernet0/2
     no ip address
     shutdown
    !
    interface Ethernet0/3
     no ip address
     shutdown
    !
    interface Serial1/0
     no ip address
     shutdown
     no fair-queue
     serial restart-delay 0
    !
    interface Serial1/1
     no ip address
     shutdown
     serial restart-delay 0
    !         
    interface Serial1/2
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/3
     no ip address
     shutdown
     serial restart-delay 0
    !
    router bgp 200
     no synchronization
     bgp log-neighbor-changes
     network 2.2.2.2 mask 255.255.255.255
     neighbor 12.1.1.1 remote-as 100
     neighbor 23.1.1.3 remote-as 300
     no auto-summary
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    ip pim bsr-candidate Loopback0 0
    ip pim rp-candidate Loopback0
    ip msdp peer 1.1.1.1 connect-source Loopback0
    ip msdp peer 3.3.3.3 connect-source Loopback0
    ip msdp cache-sa-state
    !
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
    line aux 0
    line vty 0 4
     login
    !
    exception data-corruption buffer truncate
    end
    R3===================================
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R3
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    clock timezone EST -5
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    ip source-route
    !
    !
    !         
    !
    ip cef
    no ip domain lookup
    ip multicast-routing 
    no ipv6 traffic interface-statistics
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    redundancy

    !
    !
    !
    !         
    !
    !
    !
    !
    interface Loopback0
     ip address 3.3.3.3 255.255.255.255
     ip pim sparse-mode
    !
    interface Ethernet0/0
     no ip address
    !
    interface Ethernet0/0.23
     encapsulation dot1Q 23
     ip address 23.1.1.3 255.255.255.0
     ip pim bsr-border
     ip pim sparse-mode
    !
    interface Ethernet0/0.34
     encapsulation dot1Q 34
     ip address 34.1.1.3 255.255.255.0
     ip pim sparse-mode
    !
    interface Ethernet0/0.35
     encapsulation dot1Q 35
     ip address 35.1.1.3 255.255.255.0
     ip pim sparse-mode
    !
    interface Ethernet0/1
     no ip address
     shutdown
    !
    interface Ethernet0/2
     no ip address
     shutdown
    !
    interface Ethernet0/3
     no ip address
     shutdown
    !
    interface Serial1/0
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/1
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/2
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/3
     no ip address
     shutdown
     serial restart-delay 0
    !
    router ospf 100
     log-adjacency-changes
     network 3.3.3.3 0.0.0.0 area 0
     network 34.1.1.3 0.0.0.0 area 0
     network 35.1.1.3 0.0.0.0 area 0
    !
    router bgp 300
     no synchronization
     bgp log-neighbor-changes
     network 3.3.3.3 mask 255.255.255.255
     neighbor 4.4.4.4 remote-as 300
     neighbor 4.4.4.4 update-source Loopback0
     neighbor 4.4.4.4 next-hop-self
     neighbor 5.5.5.5 remote-as 300
     neighbor 5.5.5.5 update-source Loopback0
     neighbor 5.5.5.5 next-hop-self
     neighbor 23.1.1.2 remote-as 200
     no auto-summary
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    ip msdp peer 2.2.2.2 connect-source Loopback0
    ip msdp peer 4.4.4.4 connect-source Loopback0
    ip msdp cache-sa-state
    !
    !
    !
    !
    !
    !         
    !
    control-plane
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
    line aux 0
    line vty 0 4
     login
    !
    exception data-corruption buffer truncate
    end
    R4===================================
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R4
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    clock timezone EST -5
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    ip source-route
    !
    !
    !         
    !
    ip cef
    no ip domain lookup
    ip multicast-routing 
    no ipv6 traffic interface-statistics
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    redundancy

    !
    !
    !
    !         
    !
    !
    !
    !
    interface Loopback0
     ip address 4.4.4.4 255.255.255.255
     ip pim sparse-mode
    !
    interface Ethernet0/0
     no ip address
    !
    interface Ethernet0/0.34
     encapsulation dot1Q 34
     ip address 34.1.1.4 255.255.255.0
     ip pim sparse-mode
    !
    interface Ethernet0/0.45
     encapsulation dot1Q 45
     ip address 45.1.1.4 255.255.255.0
     ip pim sparse-mode
    !
    interface Ethernet0/1
     no ip address
     shutdown
    !
    interface Ethernet0/2
     no ip address
     shutdown
    !
    interface Ethernet0/3
     no ip address
     shutdown
    !
    interface Serial1/0
     no ip address
     shutdown
     no fair-queue
     serial restart-delay 0
    !
    interface Serial1/1
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/2
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/3
     no ip address
     shutdown
     serial restart-delay 0
    !
    router ospf 100
     log-adjacency-changes
     network 0.0.0.0 255.255.255.255 area 0
    !
    router bgp 300
     no synchronization
     bgp log-neighbor-changes
     network 4.4.4.4 mask 255.255.255.255
     neighbor 3.3.3.3 remote-as 300
     neighbor 3.3.3.3 update-source Loopback0
     neighbor 5.5.5.5 remote-as 300
     neighbor 5.5.5.5 update-source Loopback0
     no auto-summary
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    ip pim bsr-candidate Loopback0 0
    ip pim rp-candidate Loopback0
    ip msdp peer 3.3.3.3 connect-source Loopback0
    ip msdp cache-sa-state
    !
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
    line aux 0
    line vty 0 4
     login
    !
    exception data-corruption buffer truncate
    end
    R5===================================

    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R5
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    clock timezone EST -5
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    ip source-route
    !
    !
    !         
    !
    ip cef
    no ip domain lookup
    ip multicast-routing 
    no ipv6 traffic interface-statistics
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    redundancy

    !
    !
    !
    !         
    !
    !
    !
    !
    interface Loopback0
     ip address 5.5.5.5 255.255.255.255
     ip pim sparse-mode
    !
    interface Ethernet0/0
     no ip address
    !
    interface Ethernet0/0.35
     encapsulation dot1Q 35
     ip address 35.1.1.5 255.255.255.0
     ip pim sparse-mode
    !
    interface Ethernet0/0.45
     encapsulation dot1Q 45
     ip address 45.1.1.5 255.255.255.0
     ip pim sparse-mode
    !
    interface Ethernet0/1
     no ip address
     shutdown
    !
    interface Ethernet0/2
     no ip address
     shutdown
    !
    interface Ethernet0/3
     no ip address
     shutdown
    !
    interface Serial1/0
     no ip address
     shutdown
     no fair-queue
     serial restart-delay 0
    !
    interface Serial1/1
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/2
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/3
     no ip address
     shutdown
     serial restart-delay 0
    !
    router ospf 100
     log-adjacency-changes
     network 0.0.0.0 255.255.255.255 area 0
    !
    router bgp 300
     no synchronization
     bgp log-neighbor-changes
     neighbor 3.3.3.3 remote-as 300
     neighbor 3.3.3.3 update-source Loopback0
     neighbor 4.4.4.4 remote-as 300
     neighbor 4.4.4.4 update-source Loopback0
     no auto-summary
    !
    ip forward-protocol nd
    !         
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
    line aux 0
    line vty 0 4
     login
    !
    exception data-corruption buffer truncate
    end


    EBGP ==================================================

  • 相关阅读:
    Java多线程系列 JUC锁03 公平锁(一)
    Java多线程系列 JUC锁02 互斥锁ReentrantLock
    JDBC课程3--通过ResultSet执行查询操作
    JDBC课程2--实现Statement(用于执行SQL语句)--使用自定义的JDBCTools的工具类静态方法,包括insert/update/delete三合一
    JDBC_通过DriverManager获得数据库连接
    JDBC课程1-实现Driver接口连接mysql数据库、通用的数据库连接方法(使用文件jdbc.properties)
    [终章]进阶20-流程控制结构--if/case/while结构
    MySQL进阶19--函数的创建(举例)/设置mysql的创建函数的权限/查看(show)/删除(drop) / 举4个栗子
    MySQL进阶18- 存储过程- 创建语句-参数模式(in/out/inout-对应三个例子) -调用语法-delimiter 结束标记'$'- 删除/查看/修改-三个练习
    SQL进阶17-变量的声明/使用(输出)--全局变量/会话变量--用户变量/局部变量
  • 原文地址:https://www.cnblogs.com/cyrusxx/p/12824086.html
Copyright © 2011-2022 走看看