zoukankan      html  css  js  c++  java
  • Evanyou Blog 彩带

      题目传送门

    Semi-prime H-numbers

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 10871   Accepted: 4881

    Description

    This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

    An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

    As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

    For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

    Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

    Input

    Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

    Output

    For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

    Sample Input

    21 
    85
    789
    0

    Sample Output

    21 0
    85 5
    789 62

    Source


      分析:

      一道素数筛法的变式题。

      把素数筛法改一下,预处理出所有答案,然后直接输出每个答案就行了。

      Code:

    //It is made by HolseLee on 2nd Sep 2018
    //POJ3292
    #include<cstdio>
    #include<cstring>
    #include<cstdlib>
    #include<cmath>
    #include<iostream>
    #include<iomanip>
    #include<algorithm>
    using namespace std;
    
    const int N=1e6+7;
    int n,ans[N],q[N],top;
    bool no[N],yes[N];
    
    int main()
    {
        ios::sync_with_stdio(false);
        for(int i=5; i<N; i+=4) {
            if(no[i])continue;
            q[++top]=i;
            for(int j=5*i; j<N; j+=i*4) no[j]=1;
        }
        for(int i=1; i<=top; ++i) 
        for(int j=1; j<=i && q[i]*q[j]<N; ++j) 
        yes[q[i]*q[j]]=1;
        for(int i=1; i<N; ++i)
        ans[i]=ans[i-1]+yes[i];
    
        while(555) {
            cin>>n; if(!n) break;
            cout<<n<<" "<<ans[n]<<"
    ";
        }
        return 0;
    }

     

  • 相关阅读:
    PHP:__get()、__set()、__isset()、__unset()、__call()、__callStatic()六个魔术方法
    概念:RPG游戏中两个兵种互相攻击的逻辑
    php怎么获取checkbox复选框的内容?
    20150724之问题
    Uploadify 之使用
    oneThink后台添加插件步骤详解
    针对各种浏览器,前端解决方案(持续更新...)
    解决IE8中select下拉列表文字上下不居中的问题
    针对IE6 7 8当独写样式
    document对象详解
  • 原文地址:https://www.cnblogs.com/cytus/p/9572886.html
Copyright © 2011-2022 走看看