zoukankan      html  css  js  c++  java
  • ZOJ

    Rearrange Them

    N people stand in a line, and we numbered them 1,2...n, and now you are asked to rearrange them. The ith people is considred in the front of the (i+1)th, after the rearrange, everyone the people in front of whom can not be the same one as before. How many different strategies you can do the rearrange.

    Input:

    Each test case just contains one integer, the number of people you have to rearrange.

    Output:

    The number of strategies you have to rearrange them, with the condition above.

    Sample Input:

    3
    4
    

    Sample Output:

    3
    11
    打表找规律,a[n]=(n-1)*a[n-1]+(n-2)*a[n-2];  n<1000;

    import java.util.Scanner;
    import java.math.BigInteger;
    public class Main {
    
    	public static void main(String[] args) {
    		BigInteger a[];a=new  BigInteger[10005];
    		a[0]=BigInteger.valueOf(0);
    		a[1]=BigInteger.valueOf(0);
    		a[2]=BigInteger.valueOf(1);
    		a[3]=BigInteger.valueOf(3);
    		a[4]=BigInteger.valueOf(11);
    		for(int i=5;i<=1000;i++) {
    			a[i]=a[i-1].multiply(BigInteger.valueOf(i-1)).add(a[i-2].multiply(BigInteger.valueOf(i-2)));
    		}
    		Scanner  read=new Scanner(System.in);
    			int x;
    		 while(read.hasNext()){ 
    			 x=read.nextInt();
    			 System.out.println(a[x]);
    		}
    	}
    }








  • 相关阅读:
    .net程序运行
    vc mscom控件串口接收不到数据问题
    vc 显示非模态对话框
    vc 使用SetWindowPos改变窗体的大小,实现折叠,展开
    c# 串口问题
    vc 电脑发声程序
    Java问题定位技术
    Java性能调优笔记
    shell解析xml文档
    Unix/Linux 的 Load 初级解释
  • 原文地址:https://www.cnblogs.com/da-mei/p/9053236.html
Copyright © 2011-2022 走看看