zoukankan      html  css  js  c++  java
  • 跳一跳游戏。《动态规划》

    动态规划的题型中要抽象出递归相类似的表达式。动态规划,给我的感觉就是一个存表和查表操作,而且这两个操作在物理和逻辑上是连续的。

    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
    Your task is to output the maximum value according to the given chessmen list.

    InputInput contains multiple test cases. Each test case is described in a line as follow:
    N value_1 value_2 …value_N
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
    A test case starting with 0 terminates the input and this test case is not to be processed.
    OutputFor each case, print the maximum according to rules, and one line one case.
    Sample Input

    3 1 3 2
    4 1 2 3 4
    4 3 3 2 1
    0

    Sample Output

    4
    10
    3

    代码如下:

    #include<iostream>
    using namespace std;
    #define Max 1000
    int max(int a, int b)
    {
     return a > b ? a : b;
    }

    int main()
    {
     int num[Max];
     int dp[Max];
     int datanum;
     while (~scanf("%d",&datanum) && datanum)
     {
      //输入数据
      for (int i = 1; i <= datanum; i++)
      {
       cin >> num[i];
       dp[i] = 0;
      }
      dp[0] = 0;
      int ans = 0;
      for (int i = 1; i <= datanum; i++)
      {
       dp[i] = num[i];
       for (int j = 1; j <= i; j++)
       {
        if (num[j] < num[i])
        {
         dp[i] = max(dp[i], dp[j] + num[i]);
        }
       }
       ans = max(ans, dp[i]);
      }
      cout << ans <<endl;
     }
     return 0;
    }

    ——————————————————————结束————————————————

    for (int i = 1; i <= datanum; i++)
      {
       dp[i] = num[i];
       for (int j = 1; j <= i; j++)
       {
        if (num[j] < num[i])
        {
         dp[i] = max(dp[i], dp[j] + num[i]);
        }
       }
       ans = max(ans, dp[i]);
      }

    这是最重要的一段,

    每输入一个值存入到dp中,然后遍历num中i后面的数字,只要比他小,就进入if中然后将dp[i]于从前的dp[i]加上当前的num的和作比较。在赋给dp[i]这是一个制表的过程。注意:当出现递减的情况,它不会进入if中,也就是说,再次遇到递增时,它是在一次从该段递增的序列中从新制表和累计的。

  • 相关阅读:
    C#类头部声明样式
    VisualStudio使用技巧及快捷键
    #使用ListView更新数据出现闪烁解决办法
    获取公网IP地址
    JArray数组每个JObject对象添加一个键值对
    部署网站出现System.ServiceModel.Activation.HttpModule错误
    MYSQL存储引擎的比较
    数据库索引原理(转载)
    皮尔逊相关系数
    进程与线程
  • 原文地址:https://www.cnblogs.com/damaoranran/p/8644445.html
Copyright © 2011-2022 走看看