zoukankan      html  css  js  c++  java
  • C

    Mickey is interested in probability recently. One day , he played a game which is about probability with mini.First mickey gives a letter and a word to mini.Then mini calculate the probability that the letter appears in the word.For example,give you the letter "a" and the word "apple". the probability of this case is 0.20000.

    InputThe input contains several test cases. Each test case consists of a letter and a word.The length of the word is no longer than 200.OutputFor each test case, print the probability rounded to five digits after the decimal point.
    Sample Input

    a apple
    c Candy
    a banana

    Sample Output

    0.20000
    0.20000
    0.50000
    注意都化为大小写字母就可以了
    #include<stdio.h>
    #include<string.h>
    int main()
    {
    char ch[201];
    char ch1;
    int len,ans; while (scanf("%c", &ch1)!=EOF)
    {
    if (ch1 < 'a') ch1 += 'a' - 'A';
    ans = 0;
    getchar();
    scanf("%s", ch);
    getchar();
    len = strlen(ch);
    for (int i = 0; i < len; i++)
    {
    if (ch[i] == ch1 || ch1 == ch[i] + 'a' - 'A') ans++;
    }
    printf("%.5lf ", (double)ans / len);
    }
    return 0;
    }
  • 相关阅读:
    dart中Map类型详解
    洛谷P1582 倒水(二进制)
    maven依赖 临时转阿里云镜像
    java jdbc 连接数据库
    java 常用类
    java 异常处理
    java 对象 this static 封装
    java 面对对象 内存分析
    团队开发 git
    java 代码块
  • 原文地址:https://www.cnblogs.com/damaoranran/p/8778252.html
Copyright © 2011-2022 走看看