zoukankan      html  css  js  c++  java
  • 杭电1075



    What Are You Talking About

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
    Total Submission(s): 7555    Accepted Submission(s): 2341


    Problem Description
    Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
     

    Input
    The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
     

    Output
    In this problem, you have to output the translation of the history book.
     

    Sample Input
    START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
     

    Sample Output
    hello, i'm from mars. i like earth!
    Hint
    Huge input, scanf is recommended.
     




    //1075
    #include <iostream>
    #include <fstream>
    #include <string>
    #include <map>
    using namespace std;
    int main()
    {
        
    	//ifstream cin("in.txt");
    	string temp;
    	string temp1;
    	
    	map<string, string> dic;
    	if (cin >> temp && strcmp(temp.c_str(), "START") == 0)
    	{
    		while (cin >> temp && strcmp(temp.c_str(),"END")!=0)
    		{
    			cin >> temp1;
    			dic[temp1] = temp;
    		}
            
    		cin >> temp;
    		cin.get();
    		if(strcmp(temp.c_str(),"START") == 0)
    		{
    			while(1)
    			{
    				getline(cin,temp);
    				if (strcmp(temp.c_str(), "END") == 0) break;
    				int i = 0;
    				while(i < temp.size())
    				{
    					temp1 = "";
    					while (i < temp.size()&&(temp[i] >= 'a' && temp[i] <= 'z' ))
    					{
    						temp1.insert(temp1.end(),temp[i]);
    						i = i + 1;
    					}
    					if (dic.find(temp1) != dic.end())
    						cout << dic[temp1];
    					else
    						cout <<temp1;
    					while ( i < temp.size()&&(temp[i] < 'a' || temp[i] > 'z'))
    					{
    						cout <<temp[i];
    						i = i + 1;
    					}
    				}
    				cout << endl;
    			}
                
    		}
    	}
    	//cin.close();
    	return 0;
    }
    


  • 相关阅读:
    Sqlite教程(1) SQLiteOpenHelper
    检查网络连接状态。
    GSON解译Json为DTO
    Okhttp教程 (1)
    HashMap的扩容算法
    回溯算法
    动态规划
    实现自旋锁
    Java堆
    垃圾回收算法总结
  • 原文地址:https://www.cnblogs.com/dancingrain/p/3405210.html
Copyright © 2011-2022 走看看