zoukankan      html  css  js  c++  java
  • 杭电1008

    Elevator

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 24941    Accepted Submission(s): 13418


    Problem Description
    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
     

    Input
    There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
     

    Output
    Print the total time on a single line for each test case. 
     

    Sample Input
    1 2 3 2 3 1 0
     

    Sample Output
    17 41



    //杭电1008
    #include <iostream>
    using namespace std;
    
    int main (int argc, char **argv)
    {
        int num ;
        while (cin >> num && num != 0)
        {
            int a = 0, b = 0;
            int coast = 0;
            for (int i =0; i < num ; ++ i )
            {
                cin >> b;
                if (b - a > 0)
                    coast += 6 * (b -a) + 5;
                else
                    coast += 4 * (a - b) + 5;
                a = b;
            }
            cout << coast << endl;
        }
    }
    


  • 相关阅读:
    Easyui使用记录
    Ubuntu 设置UFW防火墙
    MySQL 官方文档
    MySQL 版本
    MySQL主从架构之Master-Master互为主备
    MySQL主从架构之Master-Slave-Slave级联
    MySQL主从架构之Master-Slave主从同步
    Linux crond实例
    Ubuntu su: Authentication failure
    MySQL基准测试
  • 原文地址:https://www.cnblogs.com/dancingrain/p/3405221.html
Copyright © 2011-2022 走看看