zoukankan      html  css  js  c++  java
  • A

    You are working in a team that writes Incredibly Customizable Programming Codewriter (ICPC) which is basically a text editor with bells and whistles. You are working on a module that takes a piece of code containing some definitions or other tabular information and aligns each column on a fixed vertical position, while keeping the resulting code as short as possible, making sure that only whitespaces that are absolutely required stay in the code. So, that the first words on each line are printed at position p1 = 1; the second words on each line are printed at the minimal possible position p2, such that all first words end at or before position p2 - 2; the third words on each line are printed at the minimal possible position p3, such that all second words end at or before position p3 - 2, etc.

    For the purpose of this problem, the code consists of multiple lines. Each line consists of one or more words separated by spaces. Each word can contain uppercase and lowercase Latin letters, all ASCII punctuation marks, separators, and other non-whitespace ASCII characters (ASCII codes 33 to 126 inclusive). Whitespace consists of space characters (ASCII code 32).

    Input 

    The input file contains one or more lines of the code up to the end of file. All lines (including the last one) are terminated by a standard end-of-line sequence in the file. Each line contains at least one word, each word is 1 to 80 characters long (inclusive). Words are separated by one or more spaces. Lines of the code can have both leading and trailing spaces. Each line in the input file is at most 180 characters long. There are at most 1000 lines in the input file.

    Output 

    Write to the output file the reformatted, aligned code that consists of the same number of lines, with the same words in the same order, without trailing and leading spaces, separated by one or more spaces such that i-th word on each line starts at the same position pi.


    Note for the Sample:

    The `$ sqcup$' character in the example below denotes a space character in the actual files (ASCII code 32).

    Sample Input 

      start:  integer;    // begins here
    stop: integer; //  ends here  
     s:  string;   
    c:   char; // temp
    

    Sample Output 

    start: integer; // begins here 
    stop:  integer; // ends   here 
    s:     string;
    c:     char;    // temp
     
        #include <bits/stdc++.h>
        using namespace std;
        const int N = 1005, M = 200;
        string s[N][M], line;
        int cw[M], cn[N];
    
        int main()
        {
            int r = 0, c = 0;
            while(getline(cin, line))
            {
                stringstream ss(line);
                while(ss >> s[r][c])
                {
                    if(s[r][c].length() > cw[c])
                        cw[c] = s[r][c].length();
                    ++c;
                }
                cn[r++] = c;
                c = 0;
            }
    
            for(int i = 0; i < r; ++i)
            {
                for(int j = 0; j < cn[i] - 1; ++j)
                    cout << left << setw(cw[j] + 1) << s[i][j];
                cout << s[i][cn[i] - 1] << endl;
            }
            return 0;
        }
    

      

  • 相关阅读:
    Oracle数据库——半期测验
    Oracle数据库——SQL高级查询
    mysql中整数类型后面的数字,是不是指定这个字段的长度?比如int(11),11代表11个字节吗?
    ehcache memcache redis 三大缓存男高音
    Java Redis Pipeline 使用示例
    游族网络:我们是怎么玩转千台以上游戏云服务器的
    java 在Excel中插入图片 POI实现
    解放运维的双手,谈自动化运维管理平台设计
    运维堡垒机
    查询相应的key
  • 原文地址:https://www.cnblogs.com/demodemo/p/4647425.html
Copyright © 2011-2022 走看看