zoukankan      html  css  js  c++  java
  • LightOJ 1104 Birthday Paradox

    Description

    Sometimes some mathematical results are hard to believe. One of the common problems is the birthday paradox. Suppose you are in a party where there are 23 people including you. What is the probability that at least two people in the party have same birthday? Surprisingly the result is more than 0.5. Now here you have to do the opposite. You have given the number of days in a year. Remember that you can be in a different planet, for example, in Mars, a year is669 days long. You have to find the minimum number of people you have to invite in a party such that the probability of at least two people in the party have same birthday is at least 0.5.

    Input

    Input starts with an integer T (≤ 20000), denoting the number of test cases.

    Each case contains an integer n (1 ≤ n ≤ 105) in a single line, denoting the number of days in a year in the planet.

    Output

    For each case, print the case number and the desired result.

    Sample Input

    2

    365

    669

    Sample Output

    Case 1: 22

    Case 2: 30

    题意:

    假设一年有n天,你要找你的朋友来参加party,且要求至少有两个人生日相同的概率大于等于0.5的最少人数,这个就是你要邀请的最小人数。

    就是暴力啊  一个一个邀请算概率

     太水了没甚么好说的~~~~

    #include<iostream>
    using namespace std;
    int main(){
        int t,i,k=1;cin>>t;
        double p ,n;
        while(t--){
            i=0;p=1;
            cin>>n;
            while(p>0.5){
                i++;
                p*=(n-i)/n;
            }
            cout<<"Case "<<k++<<": "<<i<<endl;
        }
    return 0;
    }
    View Code
  • 相关阅读:
    [bzoj4025]二分图
    [hdu4010]: Query on The Trees
    [bzoj3514]: Codechef MARCH14 GERALD07加强版
    [hdu3943]K-th Nya Number
    [hdu5632][BC#73 1002]Rikka with Array
    在Eclipse中使用建立使用Gradle做依赖管理的Spring Boot工程
    Spring Boot 添加Shiro支持
    常用Linux命令
    HTML5之API
    JavaScript的客户端存储
  • 原文地址:https://www.cnblogs.com/demodemo/p/4749040.html
Copyright © 2011-2022 走看看